summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2018-03-05 15:41:21 +0200
committerStelios Tsampas2018-03-05 15:41:21 +0200
commit8d688e2535f5bdb7e1c36ffec0c42fcd3de2be64 (patch)
tree5589028a0643c770a07b5932304f3c01090cfb5a
downloadaur-8d688e2535f5bdb7e1c36ffec0c42fcd3de2be64.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--astylewx-destdir.patch31
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d95d533d7b91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = astylewx
+ pkgdesc = A Graphical User Interface for Artistic Style Using wxWidgets
+ pkgver = 3.1
+ pkgrel = 1
+ url = http://astyle.sourceforge.net/astylewx/
+ arch = x86_64
+ license = MIT
+ depends = wxgtk2
+ depends = astyle
+ source = https://downloads.sourceforge.net/project/astylewx.astyle.p/astylewx/astylewx 3.1/astylewx_3.1_linux.tar.gz
+ source = astylewx-destdir.patch
+ md5sums = 06a72203f953440ff254eb69940b4517
+ md5sums = cb9226bb562f88b09f57f3fd708fff3b
+
+pkgname = astylewx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c73f7a292f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stelios Tsampas <loathingkernel @at gmail .dot com>
+
+pkgname=astylewx
+pkgver=3.1
+pkgrel=1
+pkgdesc="A Graphical User Interface for Artistic Style Using wxWidgets"
+arch=('x86_64')
+url="http://astyle.sourceforge.net/astylewx/"
+license=('MIT')
+depends=('wxgtk2' 'astyle')
+source=("https://downloads.sourceforge.net/project/$pkgname.astyle.p/$pkgname/$pkgname $pkgver/${pkgname}_${pkgver}_linux.tar.gz"
+ 'astylewx-destdir.patch')
+md5sums=('06a72203f953440ff254eb69940b4517'
+ 'cb9226bb562f88b09f57f3fd708fff3b')
+
+prepare() {
+ cd "${pkgname}_${pkgver}_linux/$pkgname/build/gcc"
+ patch -p3 -i "$srcdir"/astylewx-destdir.patch
+}
+
+build() {
+ cd "${pkgname}_${pkgver}_linux/$pkgname/build/gcc"
+ make deps
+ make
+}
+
+package() {
+ cd "${pkgname}_${pkgver}_linux/$pkgname/build/gcc"
+ make DESTDIR="$pkgdir" prefix="/usr" install
+ install -Dm644 ../../LICENSE.md "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE.md
+ install -Dm644 ../../README.md "$pkgdir"/usr/share/doc/"$pkgname"/README.md
+}
diff --git a/astylewx-destdir.patch b/astylewx-destdir.patch
new file mode 100644
index 000000000000..678cc6184d57
--- /dev/null
+++ b/astylewx-destdir.patch
@@ -0,0 +1,31 @@
+--- astylewx/build/gcc/Makefile 2017-08-02 16:25:49.551415970 +0300
++++ astylewx/build/gcc/Makefile 2017-08-02 16:28:48.864180891 +0300
+@@ -162,20 +162,20 @@
+ # The two last install commands will fail if Gnome is not installed or is not at $(prefix).
+ # This is OK - just means no AStyleWx in the Gnome Applications menu
+ install:
+- $(INSTALL) -m 755 -d $(ibindir)
+- $(INSTALL) -m 755 $(bindir)/astylewx $(ibindir)
++ $(INSTALL) -m 755 -d $(DESTDIR)/$(ibindir)
++ $(INSTALL) -m 755 $(bindir)/astylewx $(DESTDIR)/$(ibindir)
+
+- $(INSTALL) -m 755 -d $(SYSCONF_PATH)
+- @mkdir -p $(SYSCONF_PATH)/html;
++ $(INSTALL) -m 755 -d $(DESTDIR)/$(SYSCONF_PATH)
++ @mkdir -p $(DESTDIR)/$(SYSCONF_PATH)/html;
+ @for files in ../../doc/*.html ../../doc/*.css; \
+ do \
+- $(INSTALL) -m 644 "$$files" $(SYSCONF_PATH)/html; \
++ $(INSTALL) -m 644 "$$files" $(DESTDIR)/$(SYSCONF_PATH)/html; \
+ done
+
+ ifdef gnomeprefix
+- $(INSTALL) -m 755 -d $(idatadir)/applications $(ipixmapdir)
+- $(INSTALL) -m 755 ../../image/AStyleWx.desktop $(idatadir)/applications/astylewx.desktop
+- $(INSTALL) -m 644 ../../image/AStyle_32.xpm $(ipixmapdir)/astyle-32.xpm
++ $(INSTALL) -m 755 -d $(DESTDIR)/$(idatadir)/applications $(DESTDIR)/$(ipixmapdir)
++ $(INSTALL) -m 755 ../../image/AStyleWx.desktop $(DESTDIR)/$(idatadir)/applications/astylewx.desktop
++ $(INSTALL) -m 644 ../../image/AStyle_32.xpm $(DESTDIR)/$(ipixmapdir)/astyle-32.xpm
+ endif
+
+ uninstall: