summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-19 14:35:45 -0400
committerGuillaume Horel2019-08-19 14:35:45 -0400
commit8d7c14649ffa77fa3a561ea03846a60362ac9978 (patch)
treeed322b19b267eb17fa41adf22ea48756a15e8adc
downloadaur-8d7c14649ffa77fa3a561ea03846a60362ac9978.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c663b9fa133
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pytest-cython
+ pkgdesc = A plugin for testing Cython extension modules.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/lgpage/pytest-cython
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/p/pytest-cython/pytest-cython-0.1.0.tar.gz
+ sha256sums = 90fa7e4e619bababeb433d3ba173a80d20473cce0bf3dce2c0e6f298becf5998
+
+pkgname = python-pytest-cython
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2efaf26b13c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-pytest-cython'
+_pkgname='pytest-cython'
+pkgver='0.1.0'
+pkgrel=1
+pkgdesc="A plugin for testing Cython extension modules."
+url="https://github.com/lgpage/pytest-cython"
+checkdepends=('python-pytest')
+depends=('python')
+makedepends=('python-setuptools')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('90fa7e4e619bababeb433d3ba173a80d20473cce0bf3dce2c0e6f298becf5998')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+#check() {
+ #cd "$srcdir/$_pkgname-${pkgver}"
+ #python setup.py test
+#}