summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-03-27 21:37:57 +0200
committerMaxime Gauduin2018-03-27 21:37:57 +0200
commit8d9cd8faf2c83f748d9cfe3d98a46e73bf56f17b (patch)
tree7cb34e4ad10859e8a4fedba2488c53c36af1fdff
parentf128f768601ab760d1b8c44aa9087c4edc56b3d2 (diff)
downloadaur-8d9cd8faf2c83f748d9cfe3d98a46e73bf56f17b.tar.gz
Switch to meson
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0a555486d3d..366670581e42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Thu May 4 22:29:37 UTC 2017
+# Tue Mar 27 19:37:57 UTC 2018
pkgbase = switchboard-plug-network-git
pkgdesc = Network plug for Switchboard
- pkgver = r582.16f3beb
+ pkgver = r799.93e3de4
pkgrel = 1
url = https://github.com/elementary/switchboard-plug-networking
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
+ makedepends = meson
makedepends = switchboard-git
makedepends = vala
depends = glib2
@@ -24,7 +23,6 @@ pkgbase = switchboard-plug-network-git
depends = libswitchboard-2.0.so
provides = switchboard-plug-network
conflicts = switchboard-plug-network
- replaces = switchboard-plug-network-bzr
source = switchboard-plug-network::git+https://github.com/elementary/switchboard-plug-networking.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 867c28be4fec..9cb2f24971d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=switchboard-plug-network-git
-pkgver=r582.16f3beb
+pkgver=r799.93e3de4
pkgrel=1
pkgdesc='Network plug for Switchboard'
arch=('x86_64')
@@ -10,10 +10,9 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('glib2' 'glibc' 'gtk3' 'libgee' 'libnm-glib' 'nm-connection-editor'
'libgranite.so' 'libswitchboard-2.0.so')
-makedepends=('cmake' 'git' 'granite-git' 'switchboard-git' 'vala')
+makedepends=('git' 'granite-git' 'meson' 'switchboard-git' 'vala')
provides=('switchboard-plug-network')
conflicts=('switchboard-plug-network')
-replaces=('switchboard-plug-network-bzr')
source=('switchboard-plug-network::git+https://github.com/elementary/switchboard-plug-networking.git')
sha256sums=('SKIP')
@@ -24,8 +23,6 @@ pkgver() {
}
prepare() {
- cd switchboard-plug-network
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -33,19 +30,16 @@ prepare() {
}
build() {
- cd switchboard-plug-network/build
+ cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib'
- make
+ arch-meson ../switchboard-plug-network
+ ninja
}
package() {
- cd switchboard-plug-network/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: