summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2022-05-14 19:51:50 +0200
committerRubenKelevra2022-05-14 19:51:50 +0200
commit8dbd3b78aacbf38baf99d8826b6d53c7a2c2b47e (patch)
tree0dea06ff3c5a56ae48f8777d94962bc1f9ed6f85
parentea91792744137b565ef68f02e965715d4ec935c8 (diff)
downloadaur-8dbd3b78aacbf38baf99d8826b6d53c7a2c2b47e.tar.gz
fix builds if ./go doesn't (yet) exist
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d49681aaba3f..9e01c7bec610 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = go-ipfs-git
pkgdesc = A peer-to-peer hypermedia distribution protocol
pkgver = 0.13.0rc1.r18.ga72753bad
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ipfs/go-ipfs
install = go-ipfs-git.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index adfc7d64e1be..af3201da2c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ DEBUG=0
_pkgname=go-ipfs
pkgname=$_pkgname-git
pkgver=0.13.0rc1.r18.ga72753bad
-pkgrel=2
+pkgrel=3
pkgdesc='A peer-to-peer hypermedia distribution protocol'
url="https://github.com/ipfs/$_pkgname"
@@ -49,9 +49,9 @@ prepare() {
cd "$srcdir/.."
# check if it was wiped due to enabled optimizations
- if [ ! -f "./go/wiped" ]; then
- chmod u+w -R "./go"
- rm -fdR ./go
+ if [ ! -f "./go/wiped" ] && [ -d "./go" ]; then
+ chmod u+w -R "./go" 2>/dev/null || true
+ rm -fdR ./go 2>/dev/null || true
fi
mkdir -p "go"