summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Bornschein2024-03-14 00:11:39 +0100
committerFabian Bornschein2024-03-14 00:11:39 +0100
commit8dcba2311d43740d63391b62fe5f623e7b045ee2 (patch)
treed47552111f00cbfa947e2b5d3ac2fadf6c0cf873
parent27739ff27e50241bd470c0f0fb99dab94e3247ef (diff)
downloadaur-8dcba2311d43740d63391b62fe5f623e7b045ee2.tar.gz
upgpkg: 5.0.10-0.1
* New stable Release * Follow Arch Linux' Rust package guidelines
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 708cc3ddd251..5c10e447ac3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = asusctl
pkgdesc = A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops
- pkgver = 5.0.8
+ pkgver = 5.0.10
pkgrel = 0.1
url = https://asus-linux.org
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = asusctl
makedepends = npm
makedepends = unzip
makedepends = yarn
- source = git+https://gitlab.com/asus-linux/asusctl.git#commit=bb7b3a81fb650b7f1e0e773b7eeb6a8d75412df5
+ source = git+https://gitlab.com/asus-linux/asusctl.git#commit=9faebe9e389ef06b81bca201bb007b740b4be984
sha256sums = SKIP
pkgname = asusctl
diff --git a/PKGBUILD b/PKGBUILD
index 487354c5398f..839042dc2ed1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
rog-control-center
gnome-shell-extension-asusctl-gnome
)
-pkgver=5.0.8
+pkgver=5.0.10
pkgrel=0.1
pkgdesc="A control daemon, tools, and a collection of crates for interacting with ASUS ROG laptops"
arch=('x86_64')
@@ -30,7 +30,7 @@ makedepends=(
"unzip"
"yarn"
)
-_commit=bb7b3a81fb650b7f1e0e773b7eeb6a8d75412df5 # tags/5.0.8^0
+_commit=9faebe9e389ef06b81bca201bb007b740b4be984 # tags/5.0.10^0
source=("git+https://gitlab.com/asus-linux/asusctl.git#commit=$_commit")
sha256sums=('SKIP')
@@ -41,6 +41,14 @@ pkgver() {
prepare() {
cd "${pkgbase}"
+
+ # Keep rust/cargo build-dependency management inside the build directory
+ export CARGO_HOME="${srcdir}/cargo"
+
+ # Follow Rust package guidelines
+ ## https://wiki.archlinux.org/title/Rust_package_guidelines
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}
build() {
@@ -48,6 +56,12 @@ build() {
# Keep rust/cargo build-dependency management inside the build directory
export CARGO_HOME="${srcdir}/cargo"
+
+ # Follow Rust package guidelines
+ ## https://wiki.archlinux.org/title/Rust_package_guidelines
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
make build
# gnome-shell extension