summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-02-08 15:32:16 +0100
committer0x9fff002020-02-08 15:32:16 +0100
commit8dd0441b65173c0812b029459d6745919430a89b (patch)
tree7f849dcde7f5695b8de7230277e4b27b374934c7
parent1d94bff4d68e185e8097445118a90840eeaa7514 (diff)
downloadaur-8dd0441b65173c0812b029459d6745919430a89b.tar.gz
update
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore32
-rw-r--r--.gitignore_append6
-rw-r--r--PKGBUILD42
-rw-r--r--idevicerestore-0001-configure.ac-check-for-pthreads.patch4
5 files changed, 73 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e51695436005..443f9d323d45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,35 @@
pkgbase = futurerestore-s0uthwest-git
pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version
- pkgver = r230.8e00751
- pkgrel = 4
+ pkgver = r248.08d0e00
+ pkgrel = 5
url = https://github.com/s0uthwest/futurerestore
arch = x86_64
license = LGPL3
makedepends = git
+ makedepends = lzfse
depends = libplist
depends = libzip
depends = libimobiledevice
depends = libfragmentzip
depends = libirecovery
- depends = libusbmuxd
depends = curl
depends = openssl
depends = zlib
- depends = lzfse
provides = futurerestore
provides = futurerestore-s0uthwest
conflicts = futurerestore
source = git+https://github.com/s0uthwest/futurerestore.git
- source = git+https://github.com/s0uthwest/img4tool.git
- source = git+https://github.com/s0uthwest/tsschecker.git
+ source = git+https://github.com/s0uthwest/img4tool-old.git
+ source = git+https://github.com/tihmstar/tsschecker.git
source = git+https://github.com/s0uthwest/idevicerestore.git
source = git+https://github.com/tihmstar/jssy.git
source = idevicerestore-0001-configure.ac-check-for-pthreads.patch
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = eb412d9b814a8d94e6f716e82559f5d5e31b5ca5267b8e28c47d72d09312ea138f448785a3f39e8798d2cd15b9f65168fda39a21ea465274d32b3b24a979ed91
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e
pkgname = futurerestore-s0uthwest-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3969bd944c22
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,32 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
+futurerestore
+img4tool-old
+tsschecker
+idevicerestore
+jssy
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..eea267266f31
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1,6 @@
+# archlinuxpackages linux
+futurerestore
+img4tool-old
+tsschecker
+idevicerestore
+jssy
diff --git a/PKGBUILD b/PKGBUILD
index 79eda0e872b6..31296d40fd3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,42 @@
# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
-pkgname=futurerestore-s0uthwest-git
-_pkgname=futurerestore
-pkgver=r230.8e00751
-pkgrel=4
+
+_name=futurerestore
+_forkname=$_name-s0uthwest
+pkgname=$_forkname-git
+pkgver=r248.08d0e00
+pkgrel=5
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
arch=('x86_64')
-url="https://github.com/s0uthwest/futurerestore"
+url="https://github.com/s0uthwest/$_name"
license=('LGPL3')
-depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'libusbmuxd' 'curl' 'openssl' 'zlib' 'lzfse')
-makedepends=('git')
-provides=('futurerestore' 'futurerestore-s0uthwest')
-conflicts=('futurerestore')
-source=('git+https://github.com/s0uthwest/futurerestore.git'
- 'git+https://github.com/s0uthwest/img4tool.git'
- 'git+https://github.com/s0uthwest/tsschecker.git'
+depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'curl' 'openssl' 'zlib')
+makedepends=('git' 'lzfse')
+provides=("$_name" "$_forkname")
+conflicts=("$_name")
+source=("git+$url.git"
+ 'git+https://github.com/s0uthwest/img4tool-old.git'
+ 'git+https://github.com/tihmstar/tsschecker.git'
'git+https://github.com/s0uthwest/idevicerestore.git'
'git+https://github.com/tihmstar/jssy.git'
'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
-sha512sums=('SKIP'
+sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'eb412d9b814a8d94e6f716e82559f5d5e31b5ca5267b8e28c47d72d09312ea138f448785a3f39e8798d2cd15b9f65168fda39a21ea465274d32b3b24a979ed91')
+ '621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$_name"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$_pkgname"
+ cd "$_name"
git submodule deinit -f --all
git submodule init
- git config submodule.external/img4tool.url "$srcdir/img4tool"
+ git config submodule.external/img4tool.url "$srcdir/img4tool-old"
git config submodule.external/tsschecker.url "$srcdir/tsschecker"
git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
git submodule update
@@ -53,7 +55,7 @@ prepare() {
}
build() {
- cd "$_pkgname"
+ cd "$_name"
CFLAGS+=' -DIDEVICERESTORE_NOMAIN=1 -DIMG4TOOL_NOMAIN=1 -DTSSCHECKER_NOMAIN=1'
./autogen.sh --prefix=/usr
@@ -61,7 +63,7 @@ build() {
}
package() {
- cd "$_pkgname"
+ cd "$_name"
make DESTDIR="$pkgdir/" install
}
diff --git a/idevicerestore-0001-configure.ac-check-for-pthreads.patch b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
index 0e55384d8792..8ef48423cffa 100644
--- a/idevicerestore-0001-configure.ac-check-for-pthreads.patch
+++ b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
@@ -1,7 +1,7 @@
From 9481d9fcf04203477dca4d503524c042fe63ab0e Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx100@gmail.com>
Date: Fri, 25 Sep 2015 23:37:27 +0300
-Subject: [PATCH 1/2] configure.ac: check for pthreads
+Subject: [PATCH] configure.ac: check for pthreads
Fixes building at least on Arch.
---
@@ -21,5 +21,5 @@ index 8f20317..df7ac04 100644
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.2.1)
PKG_CHECK_MODULES(libplist, libplist >= 1.0)
--
-2.20.1
+2.25.0