summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcbpark2017-03-31 00:05:15 +0900
committercbpark2017-03-31 00:05:15 +0900
commit8de52cb33f587e5b0e2f64352fb1486f08af060c (patch)
tree172feded6fe1982d97a92b7e8837d2b4163a1398
parentb651f2d6ea7fa44a084e979fdc6ebd19b63832dd (diff)
downloadaur-8de52cb33f587e5b0e2f64352fb1486f08af060c.tar.gz
upgpkg: softsusy 4.0-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02a79ea288b8..1eb827871224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = softsusy
pkgdesc = This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data.
- pkgver = 3.7.4
+ pkgver = 4.0
pkgrel = 1
url = http://softsusy.hepforge.org
arch = i686
arch = x86_64
license = GPL
depends = gcc-fortran
- source = http://www.hepforge.org/archive/softsusy/softsusy-3.7.4.tar.gz
- sha256sums = 0d72181549d4405067149f391b1c7ef72da932aa9b21cdd1529343386363545b
+ depends = looptools
+ source = http://www.hepforge.org/archive/softsusy/softsusy-4.0.tar.gz
+ sha256sums = 7f9b35e33ab330d279c33e1604a11cfba2a4b7503a2d0197d58de7d4239ec9cf
pkgname = softsusy
diff --git a/PKGBUILD b/PKGBUILD
index e44a331134a8..49f298153b0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
# Maintainer: Chan Beom Park <cbpark@gmail.com>
pkgname=softsusy
-pkgver=3.7.4
+pkgver=4.0
pkgrel=1
pkgdesc="This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data."
arch=("i686" "x86_64")
url="http://softsusy.hepforge.org"
license=('GPL')
-depends=("gcc-fortran")
-source=("http://www.hepforge.org/archive/softsusy/$pkgname-$pkgver.tar.gz")
-sha256sums=('0d72181549d4405067149f391b1c7ef72da932aa9b21cdd1529343386363545b')
+depends=("gcc-fortran" "looptools")
+source=("http://www.hepforge.org/archive/softsusy/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('7f9b35e33ab330d279c33e1604a11cfba2a4b7503a2d0197d58de7d4239ec9cf')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
- make
+ cd "${pkgname}-${pkgver}"
+ ./configure --enable-looptools --prefix=/usr
+ MAKEFLAGS=-j1 make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "${pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}