summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2024-01-13 15:02:06 +0100
committerThomas Lange2024-01-13 15:05:17 +0100
commit8df7500b6f07812138946fa76c862bedeaf7df01 (patch)
tree9b79a4d712b69e8aa06e24cd1bbfa63fac708992
parentf0f726785646356870e7d469f31fea64f483abb8 (diff)
downloadaur-8df7500b6f07812138946fa76c862bedeaf7df01.tar.gz
Update Git submodules
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eeb26b306e0..25b768e53b6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mumble-git
pkgdesc = An Open Source, low-latency, high quality voice chat software (git version)
- pkgver = 1.4.0.development.snapshot.006.r1121.g27e9552e8
+ pkgver = 1.4.0.development.snapshot.006.r1251.g84e881dcf
pkgrel = 1
epoch = 1
url = https://www.mumble.info
@@ -42,11 +42,12 @@ pkgbase = mumble-git
source = git+https://github.com/mumble-voip/minhook.git
source = git+https://github.com/mumble-voip/mach_override.git
source = git+https://github.com/mumble-voip/rnnoise.git
+ source = git+https://github.com/mumble-voip/SPSCQueue.git
+ source = git+https://github.com/Krzmbrzl/cmake-compiler-flags.git
source = git+https://github.com/Krzmbrzl/FindPythonInterpreter.git
source = git+https://github.com/wolfpld/tracy.git
- source = git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent
+ source = git+https://github.com/nlohmann/json.git
source = git+https://github.com/microsoft/GSL.git
- source = git+https://github.com/rigtorp/SPSCQueue.git
source = git+https://github.com/xiph/speexdsp.git
sha256sums = SKIP
sha256sums = SKIP
@@ -58,6 +59,7 @@ pkgbase = mumble-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = mumble-git
depends = gcc-libs
diff --git a/PKGBUILD b/PKGBUILD
index d50fec724a7c..fb97aa3da380 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname=mumble
pkgname="$_pkgname-git"
-pkgver=1.4.0.development.snapshot.006.r1121.g27e9552e8
+pkgver=1.4.0.development.snapshot.006.r1251.g84e881dcf
pkgrel=1
epoch=1
pkgdesc='An Open Source, low-latency, high quality voice chat software (git version)'
@@ -26,13 +26,14 @@ source=('git+https://github.com/mumble-voip/mumble.git'
'git+https://github.com/mumble-voip/minhook.git'
'git+https://github.com/mumble-voip/mach_override.git'
'git+https://github.com/mumble-voip/rnnoise.git'
+ 'git+https://github.com/mumble-voip/SPSCQueue.git'
+ 'git+https://github.com/Krzmbrzl/cmake-compiler-flags.git'
'git+https://github.com/Krzmbrzl/FindPythonInterpreter.git'
'git+https://github.com/wolfpld/tracy.git'
- 'git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent'
+ 'git+https://github.com/nlohmann/json.git'
'git+https://github.com/microsoft/GSL.git'
- 'git+https://github.com/rigtorp/SPSCQueue.git'
'git+https://github.com/xiph/speexdsp.git')
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -44,13 +45,14 @@ prepare() {
git submodule init
git config submodule.3rdparty/minhook.url "$srcdir/minhook"
git config submodule.3rdparty/mach-override-src.url "$srcdir/mach_override"
- git config submodule.3rdparty/speexdsp.url "$srcdir/speexdsp"
git config submodule.3rdparty/rnnoise-src.url "$srcdir/rnnoise"
+ git config submodule.3rdparty/SPSCQueue.url "$srcdir/SPSCQueue"
+ git config submodule.3rdparty/cmake-compiler-flags-src.url "$srcdir/cmake-compiler-flags"
git config submodule.3rdparty/FindPythonInterpreter.url "$srcdir/FindPythonInterpreter"
git config submodule.3rdparty/tracy.url "$srcdir/tracy"
- git config submodule.3rdparty/nlohmann_json.url "$srcdir/nlohmann_json_cmake_fetchcontent"
+ git config submodule.3rdparty/nlohmann_json.url "$srcdir/json"
git config submodule.3rdparty/gsl.url "$srcdir/GSL"
- git config submodule.3rdparty/SPSCQueue.url "$srcdir/SPSCQueue"
+ git config submodule.3rdparty/speexdsp.url "$srcdir/speexdsp"
git -c protocol.file.allow=always submodule update
# protobuf 23 requires C++17