summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-05-09 19:17:05 +0800
committerPumpkinCheshire2021-05-09 19:17:05 +0800
commit8e0400ac68c0617f83a3e2a83e70a9393a0f4184 (patch)
treeda3293418b0cf1a70b58ec7644aa54c98de1183c
parentc43d717d96b5921059e9246c5d9414f50455a74d (diff)
downloadaur-8e0400ac68c0617f83a3e2a83e70a9393a0f4184.tar.gz
bump to 0.16.0.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 31 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a768e2a37aa0..aa4c43438e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-pysam
pkgdesc = Python interface for the SAM/BAM sequence alignment and mapping format
- pkgver = 0.15.0
- pkgrel = 2
+ pkgver = 0.16.0.1
+ pkgrel = 1
url = https://github.com/pysam-developers/pysam
arch = x86_64
license = MIT
makedepends = python-setuptools
- makedepends = cython>=0.22
+ makedepends = cython
+ makedepends = htslib
depends = python
provides = python-pysam
options = !emptydirs
- source = https://github.com/pysam-developers/pysam/archive/v0.15.0.tar.gz
- md5sums = 80b6cd208a601b06b3778d4af33ddb89
+ source = https://github.com/pysam-developers/pysam/archive/v0.16.0.1.tar.gz
+ sha256sums = a61e98e299fa93ba121aab521081282b61bc978bb9052d33b26b38f8fe15573e
pkgname = python-pysam
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index bb15abb06e08..b9c1e935535f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
-# Maintainer: Fabio Zanini <fabio.zanini _at_ stanford.edu>
+# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+# Contributor: Fabio Zanini <fabio.zanini _at_ stanford.edu>
+
pkgname='python-pysam'
-pkgver=0.15.0
-pkgrel=2
+_name='pysam'
+pkgver=0.16.0.1
+pkgrel=1
pkgdesc="Python interface for the SAM/BAM sequence alignment and mapping format"
arch=('x86_64')
url="https://github.com/pysam-developers/pysam"
license=('MIT')
-groups=()
depends=('python')
-makedepends=('python-setuptools' 'cython>=0.22')
+makedepends=('python-setuptools' 'cython' 'htslib')
provides=('python-pysam')
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
install=
-source=("https://github.com/pysam-developers/pysam/archive/v${pkgver}.tar.gz")
-md5sums=('80b6cd208a601b06b3778d4af33ddb89')
+source=("https://github.com/pysam-developers/${_name}/archive/v${pkgver}.tar.gz")
+sha256sums=('a61e98e299fa93ba121aab521081282b61bc978bb9052d33b26b38f8fe15573e')
-package() {
- cd "$srcdir/pysam-$pkgver"
- # Use following line instead to compile with the internal htslib
- python setup.py install --root="$pkgdir/" --optimize=1
- # Use the following line to compile against external htslib from AUR (buggy)
- #HTSLIB_LIBRARY_DIR=/usr/lib HTSLIB_INCLUDE_DIR=/usr/include python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd "$srcdir/$_name-$pkgver"
+
+ export HTSLIB_LIBRARY_DIR=/usr/lib
+ export HTSLIB_INCLUDE_DIR=/usr/include
+
+ python setup.py build
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/$_name-$pkgver/COPYING" -t "$pkgdir/usr/share/licenses/$pkgname"
+}