summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Max Meyer2017-02-03 14:22:53 +0100
committerJan Max Meyer2017-02-03 14:22:53 +0100
commit8e07153996e07a74a95d693b32a706e302fe348c (patch)
tree9612c6201b00db0dc7d5664a90b9aad155420a63
parent04e2d0699028845c33a6fbf08a709d4db6ffb9ba (diff)
downloadaur-8e07153996e07a74a95d693b32a706e302fe348c.tar.gz
Updating libphorward 0.19.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11bca8737182..5ba22f661896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = phorward
- pkgdesc = C library and tools for regular expressions, lexical analysis, parsing and more.
- pkgver = 0.18.0
+ pkgdesc = A free toolkit for parser development, lexical analysis, regular expressions and more.
+ pkgver = 0.19.0
pkgrel = 1
url = http://www.phorward.info
arch = i686
arch = x86_64
arch = armv6h
license = BSD
- depends = txt2tags
- source = http://www.phorward.info/products/phorward/phorward-0.18.0-source.tar.gz
- md5sums = b2938fdbf207736bfbfa8100342c5865
+ optdepends = txt2tags: Documentation generator
+ source = http://www.phorward.info/products/phorward/phorward-0.19.0.tar.gz
+ md5sums = a0ccd26cd5462adac4da57a25d73d4b4
pkgname = phorward
diff --git a/PKGBUILD b/PKGBUILD
index 8e9ceb725751..abbee2dd333e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,32 @@
# Maintainer: Jan Max Meyer <codepilot@phorward.info>
pkgname=phorward
-pkgver=0.18.0
+pkgver=0.19.0
pkgrel=1
epoch=
-pkgdesc="C library and tools for regular expressions, lexical analysis, parsing and more."
+pkgdesc="A free toolkit for parser development, lexical analysis, regular expressions and more."
arch=('i686' 'x86_64' 'armv6h')
url="http://www.phorward.info"
license=('BSD')
-depends=('txt2tags')
makedepends=()
checkdepends=()
-#optdepends=('txt2tags: Documentation generator')
+optdepends=('txt2tags: Documentation generator')
#changelog=CHANGELOG
-source=("http://www.phorward.info/products/phorward/$pkgname-$pkgver-source.tar.gz")
-md5sums=('b2938fdbf207736bfbfa8100342c5865')
-
-prepare() {
- cd "$pkgname-$pkgver-source"
- echo "<html>Documentation coming soon.</html>" >doc/phorward.html
-}
+source=("http://www.phorward.info/products/phorward/$pkgname-$pkgver.tar.gz")
+md5sums=('a0ccd26cd5462adac4da57a25d73d4b4')
build() {
- cd "$pkgname-$pkgver-source"
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr
make
}
check() {
- cd "$pkgname-$pkgver-source"
+ cd "$pkgname-$pkgver"
make -k check
}
package() {
- cd "$pkgname-$pkgver-source"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}