summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-08-11 17:45:28 -0600
committerMark Wagie2023-08-11 17:45:28 -0600
commit8e1ec904ed0e9f60acec44f772121d3e5e569d93 (patch)
tree260ec508eabfd80426c02d4a1af8e56e2ef0c3a0
parent61e95d8d5a02a78b40c916b18238a768c58f73f7 (diff)
downloadaur-8e1ec904ed0e9f60acec44f772121d3e5e569d93.tar.gz
2.0.6
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8793b8ee59bb..ed567a2348a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-userspacefs
pkgdesc = Cross-platform user-space file systems for Python
- pkgver = 2.0.5
- pkgrel = 5
+ pkgver = 2.0.6
+ pkgrel = 1
url = https://thelig.ht/code/userspacefs
arch = any
license = GPL3
@@ -9,8 +9,10 @@ pkgbase = python-userspacefs
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- depends = python-fusepyng
- source = https://files.pythonhosted.org/packages/source/u/userspacefs/userspacefs-2.0.5.tar.gz
- sha256sums = 5d6f5ffa6d39488f1c7437c5eaae8fabf4916caceab483a3173a18e6789b186c
+ depends = python
+ conflicts = python-fusepyng
+ replaces = python-fusepyng
+ source = https://files.pythonhosted.org/packages/source/u/userspacefs/userspacefs-2.0.6.tar.gz
+ sha256sums = 5a8f4d6d4c84d01eef6df9d0b1c0c632404dea94a1c3f6d1e1c173c79c2e4d49
pkgname = python-userspacefs
diff --git a/PKGBUILD b/PKGBUILD
index 4cf0f76ea5fb..65382d878a6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=python-userspacefs
_name=${pkgname#python-}
-pkgver=2.0.5
-pkgrel=5
+pkgver=2.0.6
+pkgrel=1
pkgdesc="Cross-platform user-space file systems for Python"
arch=('any')
url="https://thelig.ht/code/userspacefs"
license=('GPL3')
-depends=('python-fusepyng')
+depends=('python')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+conflicts=('python-fusepyng')
+replaces=('python-fusepyng')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('5d6f5ffa6d39488f1c7437c5eaae8fabf4916caceab483a3173a18e6789b186c')
-
-prepare() {
- cd "$_name-$pkgver"
-
- # Relax requirements
- for f in setup.py "$_name.egg-info/requires.txt" ; do
- sed -i 's/fusepyng>=1.0.7,<2/fusepyng>=1.0.7/g' "${f}"
- done
-}
+sha256sums=('5a8f4d6d4c84d01eef6df9d0b1c0c632404dea94a1c3f6d1e1c173c79c2e4d49')
build() {
cd "$_name-$pkgver"