summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Korzun2018-08-23 17:58:00 +0300
committerAlexander Korzun2018-09-01 23:29:12 +0300
commit8e1f4910ca2302c5e042fd9fd4a24bf65216dff3 (patch)
tree00dc13b267fe8781824ba1b553dc71a9d62edb6b
downloadaur-8e1f4910ca2302c5e042fd9fd4a24bf65216dff3.tar.gz
Initial commit. Add PKGBUILD, .SRCINFO and .gitignore
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93f6f5327270
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = modbox
+ pkgdesc = A 3D game where modules loaded in runtime control most of gameplay
+ pkgver = 0.1_pre_dev
+ pkgrel = 1
+ url = https://github.com/kodo-pp/ModBox
+ arch = x86_64
+ license = MIT
+ depends = irrlicht
+ provides = modbox
+ conflicts = modbox-git
+ source = modbox-0.1_pre_dev.tar.gz::https://github.com/kodo-pp/ModBox/archive/0.1_pre_dev.tar.gz
+ source = https://github.com/kodo-pp/ModBox/releases/download/0.1_pre_dev/start-installed-modbox.sh
+ md5sums = 1e65ef7ecf9e0cc2a8c123e36c658a7d
+ md5sums = 49846d29c0f44849b043e6888b9c5cc4
+ sha256sums = d972d8f01fbf9d1328a12bc58920503199f2cd073135c18d716ec2968e0a7c5d
+ sha256sums = d761cb52f9c77c7abd3b9d926a2719cc07ffd00efa1ddb12ec12c65b81eee0f4
+
+pkgname = modbox
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02ace2f0037e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexander Korzun <korzun.sas@mail.ru>
+pkgname=modbox
+pkgver=0.1_pre_dev
+pkgrel=1
+pkgdesc="A 3D game where modules loaded in runtime control most of gameplay"
+arch=(x86_64)
+url="https://github.com/kodo-pp/ModBox"
+license=('MIT')
+depends=('irrlicht')
+provides=('modbox')
+conflicts=('modbox-git')
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/kodo-pp/ModBox/archive/$pkgver.tar.gz"
+ "https://github.com/kodo-pp/ModBox/releases/download/$pkgver/start-installed-modbox.sh"
+)
+md5sums=('1e65ef7ecf9e0cc2a8c123e36c658a7d'
+ '49846d29c0f44849b043e6888b9c5cc4')
+sha256sums=('d972d8f01fbf9d1328a12bc58920503199f2cd073135c18d716ec2968e0a7c5d'
+ 'd761cb52f9c77c7abd3b9d926a2719cc07ffd00efa1ddb12ec12c65b81eee0f4')
+
+build() {
+ cd "ModBox-$pkgver"
+ CC_TOOLCHAIN=gcc FORCE_REBUILD=yes DEBUG=no ./build.sh
+}
+
+package() {
+ cd "ModBox-$pkgver"
+ mkdir -p "$pkgdir/opt/ModBox"
+ cp -r textures "$pkgdir/opt/ModBox"
+ chmod -R 1777 "$pkgdir/opt/ModBox/textures"
+ install -Dm755 main "$pkgdir/opt/ModBox/modbox"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 ../start-installed-modbox.sh "$pkgdir/usr/bin/modbox"
+}