summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2023-11-15 08:11:11 +0100
committerNicolas Iooss2023-11-15 08:11:11 +0100
commit8e3be2cc21e1b9287cf02b0145730843be45a5e6 (patch)
tree68dd968bd756b25a641663a6965425074085eeca
parent39fed67da9a0c68b13f37109d256af05f92ea728 (diff)
downloadaur-8e3be2cc21e1b9287cf02b0145730843be45a5e6.tar.gz
systemd-selinux 254.6-2 update
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65fa4026bbde..c56804ddfe9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = systemd-selinux
pkgver = 254.6
- pkgrel = 1
+ pkgrel = 2
url = https://www.github.com/systemd/systemd
arch = x86_64
arch = aarch64
@@ -150,7 +150,7 @@ pkgname = systemd-selinux
provides = nss-myhostname
provides = systemd-tools=254.6
provides = udev=254.6
- provides = systemd=254.6-1
+ provides = systemd=254.6-2
conflicts = nss-myhostname
conflicts = systemd-tools
conflicts = udev
@@ -189,7 +189,7 @@ pkgname = systemd-libs-selinux
provides = libsystemd.so
provides = libudev.so
provides = libsystemd-selinux
- provides = systemd-libs=254.6-1
+ provides = systemd-libs=254.6-2
conflicts = libsystemd
conflicts = libsystemd-selinux
conflicts = systemd-libs
@@ -201,16 +201,16 @@ pkgname = systemd-resolvconf-selinux
depends = systemd-selinux
provides = openresolv
provides = resolvconf
- provides = systemd-resolvconf=254.6-1
+ provides = systemd-resolvconf=254.6-2
conflicts = openresolv
- conflicts = systemd-resolvconf=254.6-1
+ conflicts = systemd-resolvconf=254.6-2
pkgname = systemd-sysvcompat-selinux
pkgdesc = sysvinit compat for systemd with SELinux support
license = GPL2
depends = systemd-selinux
- provides = systemd-sysvcompat=254.6-1
- provides = selinux-systemd-sysvcompat=254.6-1
+ provides = systemd-sysvcompat=254.6-2
+ provides = selinux-systemd-sysvcompat=254.6-2
conflicts = sysvinit
conflicts = systemd-sysvcompat
conflicts = selinux-systemd-sysvcompat
@@ -225,4 +225,4 @@ pkgname = systemd-ukify-selinux
optdepends = python-pillow: Show the size of splash image
optdepends = sbsigntools: Sign the embedded kernel
provides = ukify
- provides = systemd-ukify=254.6-1
+ provides = systemd-ukify=254.6-2
diff --git a/PKGBUILD b/PKGBUILD
index 66bc00bef002..6735926b1d57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ pkgname=('systemd-selinux'
_tag='5afac6471beec5401efb51f88990eaf92f3f9507' # git rev-parse v${_tag_name}
_tag_name=254.6
pkgver="${_tag_name/-/}"
-pkgrel=1
+pkgrel=2
arch=('x86_64' 'aarch64')
url='https://www.github.com/systemd/systemd'
groups=('selinux')
@@ -232,8 +232,9 @@ package_systemd-selinux() {
mv "$pkgdir"/usr/share/man/man3 systemd-libs/man3
# ukify shipped in separate package
- install -d -m0755 systemd-ukify/{install.d,systemd,man1}
- mv "$pkgdir"/usr/lib/kernel/install.d/{60-ukify,90-uki-copy}.install systemd-ukify/install.d/
+ # we do *NOT* move the kernel-install files there, as other ways of
+ # creating uki exist!
+ install -d -m0755 systemd-ukify/{systemd,man1}
mv "$pkgdir"/usr/lib/systemd/ukify systemd-ukify/systemd/
mv "$pkgdir"/usr/share/man/man1/ukify.1 systemd-ukify/man1/
@@ -336,8 +337,7 @@ package_systemd-ukify-selinux() {
optdepends=('python-pillow: Show the size of splash image'
'sbsigntools: Sign the embedded kernel')
- install -d -m0755 "$pkgdir"/usr/{lib/kernel,share/man}
- mv systemd-ukify/install.d "$pkgdir"/usr/lib/kernel/install.d
+ install -d -m0755 "$pkgdir"/usr/{lib,share/man}
mv systemd-ukify/systemd "$pkgdir"/usr/lib/systemd
mv systemd-ukify/man1 "$pkgdir"/usr/share/man/man1
}