summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2019-09-06 11:47:06 +0300
committerSpyros Stathopoulos2019-09-06 11:47:06 +0300
commit8ea772bc35b79077c8e8fb950106a85b82e82745 (patch)
treea1faea0e04c69382234ab8fa591bfa69f1cb5bcf
parent021a0e3a42ac53b0ad12f8bf737889868bd37bd6 (diff)
downloadaur-8ea772bc35b79077c8e8fb950106a85b82e82745.tar.gz
Update to v4.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 11 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ad882fb2fd0..1688449f2c68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-gpib
pkgdesc = A support package for GPIB (IEEE 488) hardware.
- pkgver = 4.2.0
- pkgrel = 2
+ pkgver = 4.3.0
+ pkgrel = 1
url = http://linux-gpib.sourceforge.net/
install = linux-gpib.install
arch = i686
@@ -12,12 +12,12 @@ pkgbase = linux-gpib
makedepends = linux-headers
makedepends = bison
depends = bash
- depends = linux>=4.18
- depends = linux<4.19
+ depends = linux>=5.2
+ depends = linux<5.3
optdepends = fxload: firmware upload support for NI USB-B, Keithley KUSB-488 and Agilent 82357
backup = etc/gpib.conf
- source = http://downloads.sourceforge.net/project/linux-gpib/linux-gpib%20for%203.x.x%20and%202.6.x%20kernels/4.2.0/linux-gpib-4.2.0.tar.gz
- md5sums = 0241dcc2d16f6d12a7aa2c3a623a55ff
+ source = http://downloads.sourceforge.net/project/linux-gpib/linux-gpib%20for%203.x.x%20and%202.6.x%20kernels/4.3.0/linux-gpib-4.3.0.tar.gz
+ md5sums = 3085422695baf210b866601db6108860
pkgname = linux-gpib
diff --git a/PKGBUILD b/PKGBUILD
index 7a7641bc8dea..5cc831f7deb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Contributor: Alex Forenchich <alex@alexforencich.com>
pkgname=('linux-gpib')
-pkgver=4.2.0
-pkgrel=2
+pkgver=4.3.0
+pkgrel=1
pkgdesc='A support package for GPIB (IEEE 488) hardware.'
arch=('i686' 'x86_64')
url='http://linux-gpib.sourceforge.net/'
license=('GPL')
-depends=('bash' 'linux>=4.18' 'linux<4.19')
+depends=('bash' 'linux>=5.2' 'linux<5.3')
makedepends=('perl' 'python' 'linux-headers' 'bison')
optdepends=('fxload: firmware upload support for NI USB-B, Keithley KUSB-488 and Agilent 82357')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}%20for%203.x.x%20and%202.6.x%20kernels/${pkgver}/${pkgname}-${pkgver}.tar.gz")
install='linux-gpib.install'
backup=('etc/gpib.conf')
-_kernver=4.18
+_kernver=5.2
_extramodules=/usr/lib/modules/extramodules-ARCH
-md5sums=('0241dcc2d16f6d12a7aa2c3a623a55ff')
+md5sums=('3085422695baf210b866601db6108860')
prepare() {
@@ -41,17 +41,6 @@ build() {
msg "Building kernel module"
- ./bootstrap
-
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/bin \
- --disable-guile-binding \
- --enable-perl-binding \
- --disable-php-binding \
- --disable-python-binding \
- --disable-tcl-binding
make
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -59,7 +48,6 @@ build() {
msg "Building userland utils"
- ./bootstrap
./configure \
--prefix=/usr \
--sysconfdir=/etc \