summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-11-12 12:02:10 +0100
committerwillemw122021-11-12 12:02:10 +0100
commit8ee56627b5876ca71e5d14860ad21e961fb8993d (patch)
tree65a84f929e333e33c5c259a3c12ee1bbebd1cc83
parentde98e70d5410966db7b8e8f748cb14140c47edc5 (diff)
downloadaur-8ee56627b5876ca71e5d14860ad21e961fb8993d.tar.gz
Install .service, .timer and license files
Update pkgver(). Fix arch=. Minor edits.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de8008ee460b..b3b65584512d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = daily-wallpaper-git
- pkgdesc = Change wallpaper automatically with the Photo of The Day of your favorite source
- pkgver = r100.42041bf
+ pkgdesc = Change wallpaper automatically with a 'Photo of the Day'
+ pkgver = 0.8.0.r9.gad7fb04
pkgrel = 1
url = https://github.com/atareao/daily-wallpaper
- arch = x86_64
+ arch = any
license = MIT
makedepends = git
depends = dbus-python
@@ -22,4 +22,3 @@ pkgbase = daily-wallpaper-git
md5sums = SKIP
pkgname = daily-wallpaper-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 22f1b198182e..0519f789f1a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=daily-wallpaper-git
-pkgver=r100.42041bf
+pkgver=0.8.0.r9.gad7fb04
pkgrel=1
-pkgdesc="Change wallpaper automatically with the Photo of The Day of your favorite source"
-arch=('x86_64')
+pkgdesc="Change wallpaper automatically with a 'Photo of the Day'"
+arch=('any')
url="https://github.com/atareao/daily-wallpaper"
license=('MIT')
depends=('dbus-python' 'python-gobject' 'python-lxml' 'python-cssselect' 'python-requests' 'python-crontab' 'python-plumbum' 'gtk3' 'libnotify')
@@ -16,26 +16,23 @@ source=("$pkgname::git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd $pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C $pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
cd $pkgname
- install -dm755 "$pkgdir/usr"
- cp -a bin "$pkgdir/usr"
-
- install -dm755 "$pkgdir/usr/share/daily-wallpaper"
- cp -a src/*.py "$pkgdir/usr/share/daily-wallpaper"
+ install -Dm755 bin/daily-wallpaper -t "$pkgdir/usr/bin"
+ install -Dm644 data/daily-wallpaper.{service,timer} -t "$pkgdir/usr/lib/systemd/system"
+ install -Dm644 data/daily-wallpaper.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 src/dailies/* -t "$pkgdir/usr/share/${pkgname%-git}/dailies"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
- install -dm755 "$pkgdir/usr/share/daily-wallpaper"
- cp -a src/dailies "$pkgdir/usr/share/daily-wallpaper"
+ #install -Dm644 src/*.py src/dailies/* -t "$pkgdir/usr/share/${pkgname%-git}"
+ install -dm755 "$pkgdir/usr/share/${pkgname%-git}"
+ cp -a src/*.py "$pkgdir/usr/share/${pkgname%-git}"
install -dm755 "$pkgdir/usr/share/icons"
cp -a data/icons/hicolor "$pkgdir/usr/share/icons"
-
- install -dm755 "$pkgdir/usr/share/applications"
- cp -a data/daily-wallpaper.desktop "$pkgdir/usr/share/applications"
}