summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2016-12-07 18:39:26 +0100
committerBernhard Landauer2016-12-07 18:39:26 +0100
commit8ef96831154ac16825f7efb4f88aad3b024fbd34 (patch)
tree65efb0c0e2e54a33aa09332ec7b4bab3890f5e45
parent1737c6cc4376d745193fa8db33a944b3041f7e0c (diff)
downloadaur-8ef96831154ac16825f7efb4f88aad3b024fbd34.tar.gz
fix depends, update package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33f801c5b130..129d9c802665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 22:06:14 UTC 2016
+# Wed Dec 7 17:38:53 UTC 2016
pkgbase = get_flash_videos
pkgdesc = Download flash videos from a web page
- pkgver = 1.24
+ pkgver = 1.25.92
pkgrel = 1
- url = http://code.google.com/p/get-flash-videos/
+ url = https://github.com/monsieurvideo/get-flash-videos
arch = any
license = Apache
+ depends = perl-crypt-blowfish_pp
+ depends = perl-lwp-protocol-https
+ depends = perl-module-find
+ depends = perl-term-progressbar
depends = perl-www-mechanize
- depends = perl-xml-simple
- noextract = get_flash_videos-1.24
- source = http://get-flash-videos.googlecode.com/files/get_flash_videos-1.24
- md5sums = 0a02aa05e978fe111f1811eef627d440
+ noextract = get_flash_videos-1.25.92
+ source = https://github.com/monsieurvideo/get-flash-videos/releases/download/1.25.92/get_flash_videos-1.25.92
+ md5sums = 2975c1ca5af5bf993ed7b158ce711e22
pkgname = get_flash_videos
diff --git a/PKGBUILD b/PKGBUILD
index 5b1a6b9373a5..921ce72b251f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
pkgname=get_flash_videos
-pkgver=1.24
+_pkgname=get-flash-videos
+pkgver=1.25.92
pkgrel=1
pkgdesc="Download flash videos from a web page"
arch=('any')
-url="http://code.google.com/p/get-flash-videos/"
+url="https://github.com/monsieurvideo/$_pkgname"
license=('Apache')
-depends=('perl-www-mechanize' 'perl-xml-simple')
-source=(http://get-flash-videos.googlecode.com/files/$pkgname-$pkgver)
+depends=('perl-crypt-blowfish_pp'
+ 'perl-lwp-protocol-https'
+ 'perl-module-find'
+ 'perl-term-progressbar'
+ 'perl-www-mechanize')
+source=($url/releases/download/$pkgver/$pkgname-$pkgver)
+md5sums=('2975c1ca5af5bf993ed7b158ce711e22')
noextract=($pkgname-$pkgver)
package() {
- mkdir -p $pkgdir/usr/bin
- install -m755 $pkgname-$pkgver $pkgdir/usr/bin/$pkgname
+ install -Dm755 $pkgname-$pkgver $pkgdir/usr/bin/$pkgname
}
-md5sums=('0a02aa05e978fe111f1811eef627d440')