summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhys Davies2015-08-19 17:26:37 +1200
committerRhys Davies2015-08-19 17:26:37 +1200
commit8effafeaccaf13f8260f6328997021bd73ba9ad9 (patch)
tree72c1ba7bcf840a76444b2305a4a05e4647a76134
downloadaur-8effafeaccaf13f8260f6328997021bd73ba9ad9.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af1c18eb0f8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ruby-typhoeus
+ pkgdesc = Parallel HTTP library on top of libcurl multi.
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://github.com/typhoeus/typhoeus
+ arch = any
+ license = MIT
+ depends = ruby
+ depends = ruby-ethon
+ noextract = typhoeus-0.7.3.gem
+ options = !emptydirs
+ source = https://rubygems.org/downloads/typhoeus-0.7.3.gem
+ sha1sums = 7e1344b42aba92985475c708717cadc031818948
+
+pkgname = ruby-typhoeus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f894db2cc0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Generated by gem2arch (https://github.com/anatol/gem2arch)
+# Maintainer: Rhys Davies <rhys@johnguant.com>
+
+_gemname=typhoeus
+pkgname=ruby-$_gemname
+pkgver=0.7.3
+pkgrel=1
+pkgdesc='Parallel HTTP library on top of libcurl multi.'
+arch=(any)
+url='https://github.com/typhoeus/typhoeus'
+license=(MIT)
+depends=(ruby ruby-ethon)
+options=(!emptydirs)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha1sums=('7e1344b42aba92985475c708717cadc031818948')
+
+package() {
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+ install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}