summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-27 10:18:03 -0500
committerCarlos Aznarán2024-02-27 10:18:03 -0500
commit8f059c487d5c34f439eb79ba7ef5548c2c7040b4 (patch)
tree2d51d054e5f78af002a3ebe37637b8be2b2cdcd4
parent397ff0f4c61eb095d8d15b553d8e8958b5ee2a3a (diff)
downloadaur-8f059c487d5c34f439eb79ba7ef5548c2c7040b4.tar.gz
Bump version to 0.6.7
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md26
-rw-r--r--PKGBUILD6
3 files changed, 32 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50ee41c270de..b73c8a01603c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-ripser
pkgdesc = A Lean Persistent Homology Library for Python
- pkgver = 0.6.6
+ pkgver = 0.6.7
pkgrel = 1
url = https://github.com/scikit-tda/ripser.py
changelog = CHANGELOG.md
@@ -13,7 +13,7 @@ pkgbase = python-ripser
makedepends = python-wheel
makedepends = cython
depends = python-persim
- source = ripser.py-0.6.6.tar.gz::https://github.com/scikit-tda/ripser.py/archive/0.6.6.tar.gz
- sha512sums = c9128897aefad4a5e4ef27dcfc9e5fa9a04dd7b5a37b7c7818bed1eafb9f289cbda9036db2af13212652f6dea2072f5aba486e490a21f4e5da57c5990efb57dc
+ source = ripser.py-0.6.7.tar.gz::https://github.com/scikit-tda/ripser.py/archive/v0.6.7.tar.gz
+ sha512sums = a9c5026372a5bc4808d9c06cd21df3de8a3668fc382e47304a208eb29ade25c9bcee3160b97b0368302eabcdbae364786e9d9ba3baad3263f5702562351880d9
pkgname = python-ripser
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 180414612b99..7711d2f4f1c3 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,80 +1,106 @@
+# 0.6.7
+
+ - Update CD commands for newer build system.
+
# 0.6.5
+
- Bugfix for lower star filtrations with edges that come in at exactly 0 (courtesy of Riccardo Ceccaroni)
# 0.6.4
+
- Add some includes to ripser.cpp for newer Ubuntu/C++ environments
# 0.6.3
+
- Update numpy header
# 0.6.2
+
- Prevent simplex assembly in last dimension for improved memory usage (courtesy of Umberto Lupo)
# 0.6.1
+
- Lazy import plotting dependencies
# 0.6.0
+
- Update C++ backend to commit 286d369 of [ripser](https://github.com/Ripser/ripser) but keeping same functionalities
- Add support to robinhood hashmap into the C++ Backend
- Update CI in order to compile C++ with robinhood enable
- Enable Enclosing radius when threshold is set to infinity
# 0.5.5
+
- Updating CI/CD pipeline.
# 0.5.4
+
- Fixing issue with inconsistent answers from different scipy.sparse formats, courtesy of Umberto Lupo
# 0.5.3
+
- Adding link to ripser++ GPU version by Simon Zhang
# 0.5.2:
+
- Cocycle indices now correspond to point cloud indices, even
when a greedy permutation is in use
# 0.4.1:
+
- Fixed packing so C++ is MSVC compatible.
# 0.4.0:
+
- Added license to distributed packages.
# 0.3.2:
+
- Added support for greedy permutations.
- Outsourced plotting to persim.
- Outsourced data construction in examples to tadasets.
- Revamped documentation.
# 0.3.0:
+
- Completed JOSS review, thanks @lmcinnes and @arokem!!
- Documentation details updated.
# 0.2.7:
+
- Updating home url
# 0.2.6:
+
- Update license to MIT.
# 0.2.5:
+
- Docs and notebooks revamp.
- Support for Windows.
# 0.2.4:
+
- Interface redesign
# 0.2.3:
+
- Support for lower star filtrations
- Notebook on lower star filtrations
# 0.2.1:
+
- Sparse distance matrix support
- Two additional notebooks about sparsity
- Language agnostic bindings support
- Bug fixes (filtrations with low number of points)
# 0.2.0:
+
- Bug fixes (int rounding error for small magnitude threshold)
# 0.1.7:
+
- Generation of cocycles.
- Handle inf in C code and in plotting.
- Many new options for plotting diagrams.
diff --git a/PKGBUILD b/PKGBUILD
index 581d02dacba3..a07996bf1098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
_base=ripser
pkgname=python-${_base}
-pkgver=0.6.6
+pkgver=0.6.7
pkgrel=1
pkgdesc="A Lean Persistent Homology Library for Python"
arch=(x86_64)
@@ -13,8 +13,8 @@ depends=(python-persim)
makedepends=(python-build python-installer python-setuptools python-wheel cython)
checkdepends=(python-pytest)
changelog=CHANGELOG.md
-source=(${_base}.py-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('c9128897aefad4a5e4ef27dcfc9e5fa9a04dd7b5a37b7c7818bed1eafb9f289cbda9036db2af13212652f6dea2072f5aba486e490a21f4e5da57c5990efb57dc')
+source=(${_base}.py-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('a9c5026372a5bc4808d9c06cd21df3de8a3668fc382e47304a208eb29ade25c9bcee3160b97b0368302eabcdbae364786e9d9ba3baad3263f5702562351880d9')
build() {
cd ${_base}.py-${pkgver}