summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Claßen2018-12-01 16:39:18 +0100
committerPhilipp Claßen2018-12-01 16:39:18 +0100
commit8f0fe61577908af82237d6dc26a6f1f67c592aba (patch)
treeaa6bac69505c68f6f5308d212d40e1b58ff9324a
parentbcdb9b02e406c0d3460352d68f3b23c3ae3bef7b (diff)
downloadaur-8f0fe61577908af82237d6dc26a6f1f67c592aba.tar.gz
- skip tests (they will fail anyway) to remove the build dependencies "gtest" and "gmock"
- enable LTO again (the open bug ticket has been closed)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 7 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 747f5cadf44d..5192d2549c36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
# Generated by mksrcinfo v8
-# Mon Jun 11 20:35:04 UTC 2018
+# Sat Dec 1 15:39:13 UTC 2018
pkgbase = benchmark
pkgdesc = A microbenchmark support library, by Google
pkgver = 1.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/google/benchmark
arch = any
license = Apache
makedepends = cmake
- makedepends = gtest
- makedepends = gmock
depends = gcc-libs
source = https://github.com/google/benchmark/archive/v1.4.1.tar.gz
sha256sums = f8e525db3c42efc9c7f3bc5176a8fa893a9a9920bbd08cef30fb56a51854d60d
diff --git a/PKGBUILD b/PKGBUILD
index 2557d31da2f7..5d0911e616e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=benchmark
pkgver=1.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="A microbenchmark support library, by Google"
arch=('any')
url="https://github.com/google/benchmark"
license=('Apache')
depends=('gcc-libs')
-makedepends=('cmake' 'gtest' 'gmock')
+makedepends=('cmake')
source=("https://github.com/google/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('f8e525db3c42efc9c7f3bc5176a8fa893a9a9920bbd08cef30fb56a51854d60d')
@@ -18,13 +18,12 @@ prepare() {
mkdir -p build && cd build
- # For now, disable BENCHMARK_ENABLE_LTO, as it causes
- # more tests to fail and also breaks on GCC 9
- # (see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85583)
cmake .. -DCMAKE_BUILD_TYPE="Release" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=ON
+ -DBUILD_SHARED_LIBS=ON \
+ -DBENCHMARK_ENABLE_LTO=ON \
+ -DBENCHMARK_ENABLE_GTEST_TESTS=OFF
}
build() {
@@ -32,11 +31,6 @@ build() {
make
}
-check() {
- cd "${srcdir}/${pkgname}-${pkgver}/build"
- make test || echo "Ignore for now, as the test is expected to fail: https://github.com/google/benchmark/issues/578"
-}
-
package() {
cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR="$pkgdir/" install