summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Hansen2022-06-14 12:21:40 -0700
committerMichael Hansen2022-06-14 12:21:40 -0700
commit8f1c13bd9fc259441c2567e292a35c9c41417f1e (patch)
treeb4feca63315cba208b9ec7a87988a6ca7d6c3539
parent4e9962ef6bf7689290d33f0b543b0999d8611109 (diff)
downloadaur-8f1c13bd9fc259441c2567e292a35c9c41417f1e.tar.gz
Update to 1.9
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--force_qt5.patch12
3 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f1ea10e005..9e78e362db9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtextpad
pkgdesc = Lightweight cross-platform text editor using KF5's syntax highlighting repository.
- pkgver = 1.8
+ pkgver = 1.9
pkgrel = 1
url = https://github.com/zrax/qtextpad
arch = i686
@@ -8,8 +8,9 @@ pkgbase = qtextpad
license = GPL3
makedepends = cmake
depends = syntax-highlighting
- source = qtextpad-1.8.tar.gz::https://github.com/zrax/qtextpad/archive/1.8.tar.gz
- sha256sums = 7784aae4772597b7d438e8162e0df2e8a65322d66642fb996fc8e4d76b36bc31
+ source = qtextpad-1.9.tar.gz::https://github.com/zrax/qtextpad/archive/1.9.tar.gz
+ source = force_qt5.patch
+ sha256sums = 7906f15916070a08b69b851806d930730514fbcdbb02bbbf2f3ca9886fc008c9
+ sha256sums = e0e837bf92fcc23d6c93b70e25eaed35e88a4c3dbe87b848e1a13dcfcf8f9855
pkgname = qtextpad
-
diff --git a/PKGBUILD b/PKGBUILD
index 0ea4a2ab816f..59622d8ed9f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,24 @@
pkgname=qtextpad
pkgdesc="Lightweight cross-platform text editor using KF5's syntax highlighting repository."
-pkgver=1.8
+pkgver=1.9
pkgrel=1
arch=('i686' 'x86_64')
url='https://github.com/zrax/qtextpad'
license=('GPL3')
depends=('syntax-highlighting')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('7784aae4772597b7d438e8162e0df2e8a65322d66642fb996fc8e4d76b36bc31')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+ force_qt5.patch)
+sha256sums=('7906f15916070a08b69b851806d930730514fbcdbb02bbbf2f3ca9886fc008c9'
+ 'e0e837bf92fcc23d6c93b70e25eaed35e88a4c3dbe87b848e1a13dcfcf8f9855')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # KSyntaxHighlighting only supports Qt5 in Arch for now...
+ patch -p1 -i "${srcdir}/force_qt5.patch"
+}
build() {
mkdir -p "${srcdir}/build"
diff --git a/force_qt5.patch b/force_qt5.patch
new file mode 100644
index 000000000000..babf63bebfca
--- /dev/null
+++ b/force_qt5.patch
@@ -0,0 +1,12 @@
+diff -rupN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2022-06-14 12:18:25.506502296 -0700
++++ b/CMakeLists.txt 2022-06-14 12:18:38.946502190 -0700
+@@ -22,7 +22,7 @@ set(CMAKE_CXX_STANDARD 11)
+
+ include(FeatureSummary)
+
+-find_package(QT NAMES Qt6 Qt5 REQUIRED COMPONENTS Core)
++find_package(QT NAMES Qt5 REQUIRED COMPONENTS Core)
+ find_package(Qt${QT_VERSION_MAJOR} 5.6 REQUIRED COMPONENTS
+ Core Widgets PrintSupport Network)
+ if(QT_VERSION_MAJOR GREATER 5)