summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Walladge2017-08-22 17:34:12 +0930
committerSamuel Walladge2017-08-22 17:34:12 +0930
commit8f2d01c047b267e74ed7399c9a2ee7252df3cc32 (patch)
tree02327cf6df8f6d8710f1c36b1c0cfad6cd54115e
parentb1a96ccac343d1dc9bc8dd7c00feb4903cdc5700 (diff)
downloadaur-8f2d01c047b267e74ed7399c9a2ee7252df3cc32.tar.gz
update to work with new cmake build system
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43af8fe36e19..e902f1377d1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat Oct 22 00:25:56 UTC 2016
+# Tue Aug 22 08:03:37 UTC 2017
pkgbase = dreamchess-git
pkgdesc = DreamChess - OpenGL Chess Game
- pkgver = 312.c7fad45
- pkgrel = 3
+ pkgver = 365.55ffa1b
+ pkgrel = 1
url = https://github.com/dreamchess/dreamchess
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ depends = cmake
depends = mxml
depends = sdl_mixer
depends = sdl_image
diff --git a/PKGBUILD b/PKGBUILD
index 7aff84951206..20221b8a1735 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,32 @@
pkgname=dreamchess-git
_pkgname=dreamchess
-pkgver=312.c7fad45
-pkgrel=3
+pkgver=365.55ffa1b
+pkgrel=1
pkgdesc="DreamChess - OpenGL Chess Game"
arch=('i686' 'x86_64')
url="https://github.com/dreamchess/dreamchess"
license=('GPL')
-# tried to include all necessary deps and none that aren't
-# please notify if list not fully correct
-depends=(mxml sdl_mixer sdl_image glew hicolor-icon-theme)
+depends=(cmake mxml sdl_mixer sdl_image glew hicolor-icon-theme)
makedepends=(git)
source=('git://github.com/dreamchess/dreamchess.git')
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/dreamchess"
+ cd "${srcdir}/${_pkgname}"
echo "$(git rev-list --count HEAD).$(git log --pretty=format:'%h' -n 1)"
}
build() {
- cd "${srcdir}/${_pkgname}"
- # must autoreconf or missing install-sh
- autoreconf -fvi
- ./configure --prefix=/usr
+ cd "${srcdir}/${_pkgname}/cmake"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}/cmake"
make DESTDIR="${pkgdir}" install
}