summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-03-15 14:52:55 -0500
committerCarlos Aznarán Laos2022-03-15 14:52:55 -0500
commit8f5eee40a71db841919d9b78180133caa29625f6 (patch)
tree7261cebb783191c90ce49528eeab618e6949f660
parent15ec2ec73b8501a8cef221d8e55c07a8d0afc02b (diff)
downloadaur-8f5eee40a71db841919d9b78180133caa29625f6.tar.gz
Fix git sources
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 961fe47a49f2..1b492d5aa9e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,10 +2,13 @@ pkgbase = racket-git
pkgdesc = Minimal Racket installation, without DrRacket, from git
pkgver = 7.0.0.12.38897.369eb65ec2
pkgrel = 1
- url = http://racket-lang.org/
+ url = https://racket-lang.org
arch = i686
arch = x86_64
- license = LGPL
+ license = Apache
+ license = GPL3
+ license = LGPL3
+ license = custom
makedepends = git
depends = bash
depends = libffi
@@ -13,8 +16,7 @@ pkgbase = racket-git
conflicts = racket
options = !strip
options = !emptydirs
- source = git://github.com/racket/racket.git
+ source = git+https://github.com/racket/racket.git
md5sums = SKIP
pkgname = racket-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7d04e52823ae..cb4c83b25211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,36 @@
# Contributor: Paige Aran <paige.aran@gmail.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-
-pkgname=racket-git
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+_base=racket
+pkgname=${_base}-git
pkgver=7.0.0.12.38897.369eb65ec2
pkgrel=1
pkgdesc="Minimal Racket installation, without DrRacket, from git"
arch=('i686' 'x86_64')
-url="http://racket-lang.org/"
-license=('LGPL')
-depends=('bash' 'libffi')
-makedepends=('git')
-provides=('racket')
-conflicts=('racket')
+url="https://${_base}-lang.org"
+license=('Apache' 'GPL3' 'LGPL3' 'custom')
+depends=(bash libffi)
+makedepends=(git)
+provides=(${_base})
+conflicts=(${_base})
options=('!strip' '!emptydirs')
-source=("git://github.com/racket/racket.git")
-_gitname="racket"
+source=(git+https://github.com/${_base}/${_base}.git)
md5sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd ${_base}
printf %s.%s.%s \
- $(grep ' MZSCHEME_VERSION ' \
- ${srcdir}/${_gitname}/${_gitname}/src/racket/src/schvers.h \
- | cut -d '"' -f 2) "$(git rev-list --count HEAD)" $(git log -1 --format='%h')
+ $(grep ' MZSCHEME_VERSION ' \
+ ${srcdir}/${_gitname}/${_gitname}/src/racket/src/schvers.h |
+ cut -d '"' -f 2) "$(git rev-list --count HEAD)" $(git log -1 --format='%h')
}
build() {
- cd $_gitname
-
+ cd ${_base}
make in-place
}
package() {
- cd $_gitname/$_gitname
+ cd ${_base}/${_base}
install -d "$pkgdir"/usr/share/doc/racket
install -d "$pkgdir"/usr/lib
install -d "$pkgdir"/usr/share/racket/