summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authork3d32021-10-31 13:33:14 -0400
committerk3d32021-10-31 13:33:14 -0400
commit8f8ce25ed596b1289b1e01ea731e4afc2c315290 (patch)
tree29fb091dad65ae58141766118ebae82e0c931f93
parentb68be6c9ef0bab9557153f8d714bce0cf7f317d6 (diff)
downloadaur-8f8ce25ed596b1289b1e01ea731e4afc2c315290.tar.gz
Create patched wlroots-git without the argb8888/xrgb8888 check (for nvidia driver)
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--no-axrgb-assert.patch12
3 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e4314d16948..e241c2106fcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = wlroots-git
- pkgdesc = Modular Wayland compositor library (git version)
- pkgver = 0.14.0.r303.gf7ea33da
+pkgbase = wlroots-no-axrgb-assert-git
+ pkgdesc = wlroots-git, with argb/xrgb8888 assert removed to make nvidia driver work
+ pkgver = 0.14.0.r328.g8e225261
pkgrel = 1
url = https://github.com/swaywm/wlroots
arch = x86_64
@@ -24,10 +24,15 @@ pkgbase = wlroots-git
depends = vulkan-icd-loader
depends = xorg-xwayland
provides = libwlroots.so
+ provides = wlroots
+ provides = wlroots-git
provides = wlroots=0.14.0
conflicts = wlroots
+ conflicts = wlroots-git
options = debug
- source = wlroots-git::git+https://github.com/swaywm/wlroots
+ source = wlroots-no-axrgb-assert-git::git+https://github.com/swaywm/wlroots
+ source = no-axrgb-assert.patch
sha512sums = SKIP
+ sha512sums = 34cab3eb72cf0c5f1e71c2eba8da780517469b952dba0a0950960e3ac4a5d9b2043debcde884d605dda3d15ee88870b2e55bceb97bbc928b2344b38620e19ef3
-pkgname = wlroots-git
+pkgname = wlroots-no-axrgb-assert-git
diff --git a/PKGBUILD b/PKGBUILD
index 66200127e835..90e4fd788f66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
-pkgname=wlroots-git
-pkgver=0.14.0.r303.gf7ea33da
+pkgname=wlroots-no-axrgb-assert-git
+pkgver=0.14.0.r328.g8e225261
pkgrel=1
license=(custom:MIT)
-pkgdesc='Modular Wayland compositor library (git version)'
+pkgdesc='wlroots-git, with argb/xrgb8888 assert removed to make nvidia driver work'
url=https://github.com/swaywm/wlroots
arch=(x86_64)
-provides=("libwlroots.so" "wlroots=${pkgver%%.r*}")
-conflicts=(wlroots)
+provides=("libwlroots.so" "wlroots" "wlroots-git" "wlroots=${pkgver%%.r*}")
+conflicts=(wlroots wlroots-git)
options=(debug)
depends=(
glslang
@@ -30,8 +30,10 @@ makedepends=(
vulkan-headers
wayland-protocols
xorgproto)
-source=("${pkgname}::git+${url}")
-sha512sums=('SKIP')
+source=("${pkgname}::git+${url}"
+ "no-axrgb-assert.patch")
+sha512sums=('SKIP'
+ '34cab3eb72cf0c5f1e71c2eba8da780517469b952dba0a0950960e3ac4a5d9b2043debcde884d605dda3d15ee88870b2e55bceb97bbc928b2344b38620e19ef3')
pkgver () {
cd "${pkgname}"
@@ -42,6 +44,11 @@ pkgver () {
)
}
+prepare() {
+ cd "$pkgname"
+ patch --forward --strip=1 --input="${srcdir}/no-axrgb-assert.patch"
+}
+
build () {
arch-meson \
--buildtype=debug \
diff --git a/no-axrgb-assert.patch b/no-axrgb-assert.patch
new file mode 100644
index 000000000000..edbd7da33348
--- /dev/null
+++ b/no-axrgb-assert.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text wlroots-no-axrgb-assert-git.orig/render/wlr_renderer.c wlroots-no-axrgb-assert-git.new/render/wlr_renderer.c
+--- wlroots-no-axrgb-assert-git.orig/render/wlr_renderer.c 2021-10-31 09:12:25.561443998 -0400
++++ wlroots-no-axrgb-assert-git.new/render/wlr_renderer.c 2021-10-31 09:13:24.259093275 -0400
+@@ -227,7 +227,7 @@
+ wl_display_add_shm_format(wl_display, fmt);
+ }
+ }
+- assert(argb8888 && xrgb8888);
++ // assert(argb8888 && xrgb8888);
+
+ if (wlr_renderer_get_dmabuf_texture_formats(r) != NULL) {
+ if (wlr_renderer_get_drm_fd(r) >= 0) {