summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-10-28 11:04:16 +0100
committerwillemw122015-10-28 11:10:26 +0100
commit8f8d50ab4759bbc6d8bd1ec0393ada969bee84de (patch)
treed526337dd4561ab5ad0db5db4ee973d02f9a0210
downloadaur-8f8d50ab4759bbc6d8bd1ec0393ada969bee84de.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6670b7ad935
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v7
+# Wed Oct 28 10:10:14 UTC 2015
+pkgbase = podfox-git
+ pkgdesc = Catch and manage podcasts from the terminal
+ pkgver = r48.fa8da28
+ pkgrel = 1
+ url = https://github.com/brtmr/podfox
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-colorama
+ depends = python-feedparser
+ depends = python-pycurl
+ provides = podfox
+ conflicts = podfox
+ source = podfox-git::git://github.com/brtmr/podfox.git
+ md5sums = SKIP
+
+pkgname = podfox-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b4b4c214207
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+_pkgname=podfox
+pkgname=$_pkgname-git
+pkgver=r48.fa8da28
+pkgrel=1
+pkgdesc="Catch and manage podcasts from the terminal"
+arch=('any')
+url="https://github.com/brtmr/podfox"
+license=('GPL3')
+makedepends=('git')
+depends=('python-colorama' 'python-feedparser' 'python-pycurl')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::git://github.com/brtmr/podfox.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 podfox.py "$pkgdir/usr/bin/podfox"
+}
+