summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-02-09 20:45:40 +0100
committersL1pKn072019-02-09 20:45:40 +0100
commit8f91e1cefde36e301e28a0e5d3a6893fc50eeb1a (patch)
tree6d362c7d7de62c5c39ec64966774c7941df1715f
downloadaur-8f91e1cefde36e301e28a0e5d3a6893fc50eeb1a.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26dd848ef79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Feb 9 19:45:40 UTC 2019
+pkgbase = vapoursynth-plugin-dfmderainbow-git
+ pkgdesc = Plugin for Vapoursynth: dfmderainbow (GIT version)
+ pkgver = v1.0.g2c68baa
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-dfmderainbow
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-temporalmedian-git
+ depends = vapoursynth-plugin-temporalsoften2-git
+ depends = vapoursynth-plugin-fluxsmooth-git
+ depends = vapoursynth-plugin-msmoosh-git
+ depends = vapoursynth-plugin-minideen-git
+ provides = vapoursynth-plugin-dfmderainbow
+ conflicts = vapoursynth-plugin-dfmderainbow
+ source = dfmderainbow::git+https://github.com/dubhater/vapoursynth-dfmderainbow.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-dfmderainbow-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ea404ef33ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=dfmderainbow
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.g2c68baa
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth-plugin-temporalmedian-git'
+ 'vapoursynth-plugin-temporalsoften2-git'
+ 'vapoursynth-plugin-fluxsmooth-git'
+ 'vapoursynth-plugin-msmoosh-git'
+ 'vapoursynth-plugin-minideen-git'
+ )
+optdepend=('vapoursynth-plugin-mvtools-git'
+ 'vapoursynth-plugin-fft3dfilter-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package(){
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}