summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob (Jack/XDjackieXD)2023-09-07 02:42:38 +0200
committerJakob (Jack/XDjackieXD)2023-09-07 02:42:38 +0200
commit8fae61b676e097f39d951a9452a3c117badf1a43 (patch)
tree6ef8e307df160896ad55dcfb6ad65eb4818d4e00
parent18713ec9f069ef1f6107c86dbefcbd05a92260ca (diff)
downloadaur-8fae61b676e097f39d951a9452a3c117badf1a43.tar.gz
update to gnuradio 3.10 branch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 18 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6e1688fa47..27be308c7b4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gr-satnogs-git
pkgdesc = gr-satnogs from librespacefoundation
- pkgver = r584.1103a05
+ pkgver = r627.af9b14d
pkgrel = 1
url = https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git
arch = x86_64
@@ -10,17 +10,19 @@ pkgbase = gr-satnogs-git
makedepends = cmake
makedepends = swig
depends = gnuradio
- depends = gr-soapy
depends = png++
depends = nlohmann-json
depends = libvorbis
depends = libogg
depends = libvolk
depends = libpng
+ depends = itpp
+ depends = hamlib
provides = gr-satnogs
conflicts = gr-satnogs
- source = git+https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git
+ source = git+https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git#branch=gnuradio-3.10
+ source = git+https://github.com/d-bahr/CRCpp.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = gr-satnogs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8dbb5a8767f5..304951846f33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: Jakob (XDjackieXD) <aur at chaosfield dot at>
pkgname=gr-satnogs-git
-pkgver=r584.1103a05
+pkgver=r627.af9b14d
pkgrel=1
pkgdesc="gr-satnogs from librespacefoundation"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/librespacefoundation/satnogs/gr-satnogs.git"
license=('GPL3')
-depends=('gnuradio' 'gr-soapy' 'png++' 'nlohmann-json' 'libvorbis' 'libogg' 'libvolk' 'libpng')
+depends=('gnuradio' 'png++' 'nlohmann-json' 'libvorbis' 'libogg' 'libvolk' 'libpng' 'itpp' 'hamlib')
makedepends=('git' 'cmake' 'swig')
provides=('gr-satnogs')
conflicts=('gr-satnogs')
-source=("git+$url")
-sha256sums=('SKIP')
+source=("git+$url#branch=gnuradio-3.10" "git+https://github.com/d-bahr/CRCpp.git")
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd gr-satnogs
@@ -20,6 +21,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd gr-satnogs
+ git submodule init
+ git config submodule.CRCpp.url "$srcdir/CRCpp"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
mkdir -p gr-satnogs/build
cd gr-satnogs/build