summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2020-03-10 03:24:11 +0300
committerViktor Drobot2020-03-10 03:24:11 +0300
commit8fdb03796a55d0c5868f3e41fc4046bbebb5967f (patch)
tree663d3b4b2cabe5cb6f92d851430f602c521f3199
parent182817509abcb0cf61a56fec3024ffee7a64f2e5 (diff)
downloadaur-8fdb03796a55d0c5868f3e41fc4046bbebb5967f.tar.gz
Fixed PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09f38215d234..79ed934e92a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = r-corpus
- pkgdesc = Corpus data analysis R tools with unicode support
+ pkgdesc = Text Corpus Analysis
pkgver = 0.10.0
- pkgrel = 3
- url = http://cran.r-project.org/web/packages/corpus/index.html
+ pkgrel = 1
+ url = https://cran.r-project.org/package=corpus
arch = i686
arch = x86_64
- license = Apache-2.0
- depends = r>=3.0.1
- depends = r-utf8
- conflicts = r-corpus
- source = http://cran.r-project.org/src/contrib/corpus_0.10.0.tar.gz
- sha256sums = 7458f654757d096d1739147e43ba02358cfe5c9b14042d6ac622aa6575262831
+ license = Apache2.0
+ makedepends = gcc
+ depends = r>=3.3
+ depends = r-utf8>=1.1.0
+ optdepends = r-knitr
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/corpus_0.10.0.tar.gz
+ md5sums = e04afcf4e56ed90fdde829399913e1c5
pkgname = r-corpus
diff --git a/PKGBUILD b/PKGBUILD
index 996c8738681a..c5ab7ca17871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,30 @@
-# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Clint Valentine <valentine.clint@gmail.com>
_cranname=corpus
_cranver=0.10.0
-pkgname="r-${_cranname}"
-pkgver="${_cranver}"
-pkgrel=3
-pkgdesc="Corpus data analysis R tools with unicode support"
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('i686' 'x86_64')
-license=('Apache-2.0')
-depends=('r>=3.0.1' 'r-utf8')
-conflicts=('r-corpus')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('7458f654757d096d1739147e43ba02358cfe5c9b14042d6ac622aa6575262831')
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Text Corpus Analysis"
+arch=(i686 x86_64)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(Apache2.0)
+depends=('r>=3.3' 'r-utf8>=1.1.0')
+makedepends=(gcc)
+optdepends=(r-knitr r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('e04afcf4e56ed90fdde829399913e1c5')
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
package() {
- mkdir -p "${pkgdir}/usr/lib/R/library"
- cd "${srcdir}"
- R CMD INSTALL "${_cranname}" -l "${pkgdir}/usr/lib/R/library"
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}