summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfab2016-02-09 15:05:24 +0100
committerfab2016-02-09 15:05:24 +0100
commit8ff41e6c8dd4681ada066499f32a510b7c97a61e (patch)
tree38a6b51d6ac92d87bfdebcec8fec6e5d8e18bb25
downloadaur-8ff41e6c8dd4681ada066499f32a510b7c97a61e.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD46
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1fe2e40d42c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = volpack
+ pkgdesc = Enhanced Philippe Lacroute's volpack volume rendering library
+ pkgver = 1.0c7
+ pkgrel = 1
+ url = http://amide.sourceforge.net/packages.html
+ arch = any
+ license = GPL
+ source = http://sourceforge.net/projects/amide/files/volpack/1.0c7/volpack-1.0c7.tgz/download
+ md5sums = 119ec828ecad8dbf7afc4e71f4c4eb69
+
+pkgname = volpack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76184c54eb1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Fabien Devaux <fdev31@gmail.com>
+pkgname=volpack
+pkgver=1.0c7
+pkgrel=1
+epoch=
+pkgdesc="Enhanced Philippe Lacroute's volpack volume rendering library"
+arch=("any")
+url="http://amide.sourceforge.net/packages.html"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://sourceforge.net/projects/amide/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tgz/download")
+noextract=()
+md5sums=("119ec828ecad8dbf7afc4e71f4c4eb69")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}