summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElmar Klausmeier2020-02-17 18:55:12 +0100
committerElmar Klausmeier2020-02-17 18:55:12 +0100
commit9010e9d6833523a12b63e447bcd07568dc6195d2 (patch)
treee50084dda53fbd28e18fbdc01062d3fd2ce825e8
parent00b47913542aad2e102f9777767fcebc9d48e14d (diff)
downloadaur-9010e9d6833523a12b63e447bcd07568dc6195d2.tar.gz
New maintainer, bumped to version 3.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD41
2 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eda610f2a41..72dd37864d4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = libwebsockets-libuv
pkgdesc = C library for websocket clients and servers (compiled with libuv support)
- pkgver = 2.1.0
+ pkgver = 3.2
pkgrel = 1
url = https://libwebsockets.org
arch = i686
arch = x86_64
+ arch = armv7h
license = LGPL
makedepends = cmake
depends = openssl
@@ -12,8 +13,8 @@ pkgbase = libwebsockets-libuv
provides = libwebsockets
conflicts = libwebsockets
replaces = libwebsockets
- source = https://github.com/warmcat/libwebsockets/archive/v2.1.0.tar.gz
- md5sums = 4df3be57dee43aeebd54a3ed56568f50
+ source = https://libwebsockets.org/git/libwebsockets/snapshot/libwebsockets-v3.2-stable.tar.gz
+ sha256sums = 3b10d3198b12b07108e38f11b88345715335ddc82e2c2d4980f5b8556ca97048
pkgname = libwebsockets-libuv
diff --git a/PKGBUILD b/PKGBUILD
index 0e58b5f428ed..166cd741ea60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: Mark Vainomaa <mikroskeem@mikroskeem.eu>
-
# This PKGBUILD is based off from libwebsockets package
# Original package maintainer: Jelle van der Waa <jelle@archlinux.org>
# Original package contributor: Jingbei Li <i@jingbei.li>
+# Previous maintainer: Mark Vainomaa <mikroskeem@mikroskeem.eu>
+# Maintainer: Elmar Klausmeier <Elmar.Klausmeier@gmail.com>
-_lws=libwebsockets
-pkgname=${_lws}-libuv
-pkgver=2.1.0
+pkgname=libwebsockets-libuv
+pkgver=3.2
pkgrel=1
pkgdesc="C library for websocket clients and servers (compiled with libuv support)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'armv7h')
url="https://libwebsockets.org"
depends=('openssl' 'libuv')
makedepends=('cmake')
@@ -17,23 +16,31 @@ conflicts=('libwebsockets')
provides=('libwebsockets')
replaces=('libwebsockets')
license=('LGPL')
-source=("https://github.com/warmcat/libwebsockets/archive/v$pkgver.tar.gz")
-md5sums=('4df3be57dee43aeebd54a3ed56568f50')
+source=("https://libwebsockets.org/git/libwebsockets/snapshot/libwebsockets-v$pkgver-stable.tar.gz")
+sha256sums=('3b10d3198b12b07108e38f11b88345715335ddc82e2c2d4980f5b8556ca97048')
build() {
- cd "${_lws}-${pkgver}/"
+ cd "libwebsockets-v${pkgver}-stable"
- mkdir build && cd build
- cmake -D CMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX:PATH=/usr -DLWS_WITH_LIBUV=ON ..
- make
+ mkdir build && cd build
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DLWS_WITH_STATIC=OFF \
+ -DLWS_LINK_TESTAPPS_DYNAMIC=ON \
+ -DLWS_UNIX_SOCK=ON \
+ -DLWS_IPV6=ON \
+ -DLWS_WITH_LIBUV=ON \
+ ..
+ make
}
package() {
- cd "${_lws}-${pkgver}/build"
- make DESTDIR="${pkgdir}" install
+ cd "libwebsockets-v${pkgver}-stable/build"
+ make DESTDIR="${pkgdir}" install
- cd ..
+ cd ..
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
}
+