summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Brown2019-01-01 03:09:46 +0000
committerTimothy Brown2019-01-01 03:09:46 +0000
commit901dd9ba1b66546b976b1c9a7bc6f4b894774620 (patch)
treeea103544b29a90ac707ad8c1017e4256c53224db
parent36cf63d2d73210e58c0c70185e70dee948c17a7a (diff)
downloadaur-901dd9ba1b66546b976b1c9a7bc6f4b894774620.tar.gz
Added patch to fix makefile install permissions.
-rw-r--r--.SRCINFO4
-rw-r--r--Makefile.patch13
-rw-r--r--PKGBUILD15
3 files changed, 26 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 463eecd6e982..031855a36f9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = adjtimex
pkgdesc = Allows configuration of kernel time variables
pkgver = 1.29_10
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rogers0/adjtimex
arch = x86_64
arch = arm
@@ -11,7 +11,9 @@ pkgbase = adjtimex
license = GPL2
depends = glibc
source = adjtimex-1.29-10.tar.gz::https://github.com/rogers0/adjtimex/archive/debian/1.29-10.tar.gz
+ source = Makefile.patch
md5sums = 56e5c86c5fd5ef95d18673b2ed18e3f7
+ md5sums = 49548b8d3ad85bdb8e62da2d7d61f8d9
pkgname = adjtimex
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..7bd2a178b232
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,13 @@
+diff -ruN adjtimex-debian-1.29-10.old/Makefile.in adjtimex-debian-1.29-10/Makefile.in
+--- adjtimex-debian-1.29-10.old/Makefile.in 2018-07-25 17:02:11.000000000 +0000
++++ adjtimex-debian-1.29-10/Makefile.in 2019-01-01 02:58:05.867107891 +0000
+@@ -42,7 +42,8 @@
+ $(CC) $(CFLAGS) -c mat.c
+
+ install: all
+- $(INSTALL) -g bin -m 755 -o root adjtimex $(bindir)/adjtimex
++ $(INSTALL) -d -g root -m 755 -o root $(bindir)
++ $(INSTALL) -g root -m 755 -o root adjtimex $(bindir)/adjtimex
+ $(INSTALL) -d -g root -m 755 -o root $(mandir)
+ -$(INSTALL) -g root -m 644 -o root $(srcdir)/adjtimex.8 \
+ $(mandir)/adjtimex.$(manext)
diff --git a/PKGBUILD b/PKGBUILD
index c173281dbc19..b19e106270f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,21 @@
# Maintainer: Timothy Brown <sysop@timb.us>
pkgname=adjtimex
pkgver=1.29_10
-pkgrel=1
+pkgrel=2
pkgdesc="Allows configuration of kernel time variables"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/rogers0/adjtimex"
license=('GPL2')
depends=('glibc')
source=("$pkgname-${pkgver//_/-}.tar.gz::https://github.com/rogers0/adjtimex/archive/debian/${pkgver//_/-}.tar.gz"
- )
+ Makefile.patch)
+md5sums=('56e5c86c5fd5ef95d18673b2ed18e3f7'
+ '49548b8d3ad85bdb8e62da2d7d61f8d9')
+prepare() {
+ cd "$pkgname-debian-${pkgver//_/-}"
+ patch -p1 -i ../../Makefile.patch Makefile.in
+}
+
build() {
cd "$pkgname-debian-${pkgver//_/-}"
./configure --prefix=/usr
@@ -17,8 +24,6 @@ build() {
package() {
cd "$pkgname-debian-${pkgver//_/-}"
- install -d ${pkgdir}/usr/{bin,share/man/man8}
+ #install -d ${pkgdir}/usr/{bin,share/man/man8}
make prefix="$pkgdir/usr" bindir="$pkgdir/usr/bin" install
- chown root:root $pkgdir/usr/bin/adjtimex
}
-md5sums=('56e5c86c5fd5ef95d18673b2ed18e3f7')