summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFFY002018-10-07 23:30:17 +0100
committerFFY002018-10-07 23:30:17 +0100
commit90287a5d3dd3110a1a95f6f3e26bbc4c87873fc0 (patch)
treee44bc77f1aa311318051fe0e15fbde493a5d34b2
parent8191b60d3ce9328ab095b600b197b43ec6090d3a (diff)
downloadaur-90287a5d3dd3110a1a95f6f3e26bbc4c87873fc0.tar.gz
bump version to 4.2.8.4421
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec39a57c468..1e390bd8680b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = synology-cloud-station-drive
pkgdesc = An application which sync files between your computers and Synology NAS
- pkgver = 4.2.7.4415
+ pkgver = 4.2.8.4421
pkgrel = 1
url = https://www.synology.com/en-global/releaseNote/CloudStationDrive
arch = i686
arch = x86_64
- license = Custom
+ license = custom
optdepends = nautilus: Nautilus integration
- source_i686 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.2.7-4415/Ubuntu/Installer/i686/synology-cloud-station-drive-4415.i686.deb
- sha256sums_i686 = 9a7b088d26edc3f53928818dd48a244cc75c0afd552231c67046692781e7e786
- source_x86_64 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.2.7-4415/Ubuntu/Installer/x86_64/synology-cloud-station-drive-4415.x86_64.deb
- sha256sums_x86_64 = 9caeff7d7a5331150531a2dda492a74672082550d57463c8d122452dcb7bc5d7
+ source_i686 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.2.8-4421/Ubuntu/Installer/i686/synology-cloud-station-drive-4421.i686.deb
+ sha512sums_i686 = daea19fa7f63e38350ff9c50910599eaec749b431b1eb54bbd7d0b118d49efd0232f47cfe83a1d26b60e9f36b80968f25b8b9eb881b4e59ca2de3895a791d53a
+ source_x86_64 = https://global.download.synology.com/download/Tools/CloudStationDrive/4.2.8-4421/Ubuntu/Installer/x86_64/synology-cloud-station-drive-4421.x86_64.deb
+ sha512sums_x86_64 = 5b46eec7a2f965aa7d35518064acaece067a6d42940631b93d672c83f0afac0ba5057d76112d76e51c32d74a2f8c33342e527d92f3c910e9e3006d8fb1938ac7
pkgname = synology-cloud-station-drive
diff --git a/PKGBUILD b/PKGBUILD
index 8c829d9a3300..c1728d794c86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: Filipe Laíns <filiipe.lains@gmail.com>
+# Maintainer: Filipe Laíns (FFY00) <lains@archlinux.org>
# Contributor: Lev Lybin <aur@devtrue.net>
+
pkgname=synology-cloud-station-drive
-_iver=4415
-_rver=4.2.7
+_iver=4421
+_rver=4.2.8
pkgver=$_rver.$_iver
pkgrel=1
-pkgdesc="An application which sync files between your computers and Synology NAS"
+pkgdesc='An application which sync files between your computers and Synology NAS'
arch=('i686' 'x86_64')
-url="https://www.synology.com/en-global/releaseNote/CloudStationDrive"
-license=('Custom')
+url='https://www.synology.com/en-global/releaseNote/CloudStationDrive'
+license=('custom')
optdepends=('nautilus: Nautilus integration')
-source_x86_64=("https://global.download.synology.com/download/Tools/CloudStationDrive/${_rver}-${_iver}/Ubuntu/Installer/x86_64/synology-cloud-station-drive-${_iver}.x86_64.deb")
-sha256sums_x86_64=('9caeff7d7a5331150531a2dda492a74672082550d57463c8d122452dcb7bc5d7')
-source_i686=("https://global.download.synology.com/download/Tools/CloudStationDrive/${_rver}-${_iver}/Ubuntu/Installer/i686/synology-cloud-station-drive-${_iver}.i686.deb")
-sha256sums_i686=('9a7b088d26edc3f53928818dd48a244cc75c0afd552231c67046692781e7e786')
+source_x86_64=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/x86_64/synology-cloud-station-drive-$_iver.x86_64.deb")
+source_i686=("https://global.download.synology.com/download/Tools/CloudStationDrive/$_rver-$_iver/Ubuntu/Installer/i686/synology-cloud-station-drive-$_iver.i686.deb")
+sha512sums_i686=('daea19fa7f63e38350ff9c50910599eaec749b431b1eb54bbd7d0b118d49efd0232f47cfe83a1d26b60e9f36b80968f25b8b9eb881b4e59ca2de3895a791d53a')
+sha512sums_x86_64=('5b46eec7a2f965aa7d35518064acaece067a6d42940631b93d672c83f0afac0ba5057d76112d76e51c32d74a2f8c33342e527d92f3c910e9e3006d8fb1938ac7')
prepare() {
cd "$srcdir"
+
tar -zxf "$srcdir"/data.tar.gz
}
@@ -29,3 +31,4 @@ package() {
install -Dm644 "$srcdir"/opt/Synology/CloudStation/LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+