summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2016-06-14 08:15:36 +0200
committerDaniel Peukert2016-06-14 08:40:35 +0200
commit9032532df87c19456b6b35327d134157183af798 (patch)
tree3a1d18680911f97024cd03c77f416e9900850c68
downloadaur-9032532df87c19456b6b35327d134157183af798.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD27
-rw-r--r--cloudprint-cups.install7
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fccec698310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = cloudprint-cups
+ pkgdesc = Google Cloud Print driver for CUPS, allows printing to printers hosted on Google Cloud Print.
+ pkgver = 20160502
+ pkgrel = 1
+ url = https://github.com/simoncadman/CUPS-Cloud-Print
+ install = cloudprint-cups.install
+ arch = any
+ license = GPL3
+ makedepends = cups
+ depends = python2
+ depends = python2-pycups
+ depends = python2-httplib2
+ depends = python2-six
+ provides = cloudprint-cups
+ provides = cupscloudprint
+ conflicts = cloudprint-cups
+ conflicts = cloudprint-cups-git
+ conflicts = cupscloudprint
+ options = !emptydirs
+ source = https://github.com/simoncadman/CUPS-Cloud-Print/archive/20160502.tar.gz
+ md5sums = c8fffd89b94032c562aa43c924b94a17
+
+pkgname = cloudprint-cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a0de0a45cd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com> (based on the PKGBUILD from cloudprint-cups-git by mortzu and zizzfizzix)
+pkgname=cloudprint-cups
+pkgver=20160502
+pkgrel=1
+pkgdesc='Google Cloud Print driver for CUPS, allows printing to printers hosted on Google Cloud Print.'
+arch=('any')
+url='https://github.com/simoncadman/CUPS-Cloud-Print'
+license=('GPL3')
+depends=('python2' 'python2-pycups' 'python2-httplib2' 'python2-six')
+makedepends=('cups')
+provides=('cloudprint-cups' 'cupscloudprint')
+conflicts=('cloudprint-cups' 'cloudprint-cups-git' 'cupscloudprint')
+options=(!emptydirs)
+install=cloudprint-cups.install
+source=("https://github.com/simoncadman/CUPS-Cloud-Print/archive/$pkgver.tar.gz")
+md5sums=('c8fffd89b94032c562aa43c924b94a17')
+
+build() {
+ cd "$srcdir/CUPS-Cloud-Print-$pkgver"
+ ./configure --prefix /usr
+ make
+}
+
+package() {
+ cd "$srcdir/CUPS-Cloud-Print-$pkgver"
+ NOPERMS=1 make DESTDIR="$pkgdir" install
+}
diff --git a/cloudprint-cups.install b/cloudprint-cups.install
new file mode 100644
index 000000000000..829862e78c1a
--- /dev/null
+++ b/cloudprint-cups.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo 'Run "sudo /usr/share/cloudprint-cups/setupcloudprint.py" to set up.'
+}
+
+post_upgrade() {
+ /usr/share/cloudprint-cups/upgrade.py
+}