summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Rustand2019-09-01 00:44:03 +0200
committerLars Rustand2019-09-01 00:44:03 +0200
commit903c04e012d68827474624025ddc40107db8152d (patch)
treee838df66fbf996285548c6fbf1418f7aec886651
parentf9e08ef0ee05eb56efb5961219d5b8ad549f3fd0 (diff)
downloadaur-903c04e012d68827474624025ddc40107db8152d.tar.gz
Update to 4.17.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--iconsupport.patch32
3 files changed, 14 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4117098b73d5..a21823e8bf8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = i3-wm-iconpatch
pkgdesc = An improved dynamic tiling window manager (with titlebar icon patch)
- pkgver = 4.16.1
+ pkgver = 4.17.1
pkgrel = 1
url = http://i3wm.org/
arch = i686
@@ -29,13 +29,13 @@ pkgbase = i3-wm-iconpatch
conflicts = i3-wm
options = docs
options = !strip
- source = http://i3wm.org/downloads/i3-4.16.1.tar.bz2
- source = http://i3wm.org/downloads/i3-4.16.1.tar.bz2.asc
+ source = http://i3wm.org/downloads/i3-4.17.1.tar.bz2
+ source = http://i3wm.org/downloads/i3-4.17.1.tar.bz2.asc
source = iconsupport.patch
validpgpkeys = 424E14D703E7C6D43D9D6F364E7160ED4AC8EE1D
- sha1sums = 95607b8e09bdf5d18032b2ec391cb1000efcdf5a
+ sha1sums = 1834ce349a2aea2fbb0d44d9ed820fa9e1a394ab
sha1sums = SKIP
- sha1sums = 2ccc24022d4bbf1b1f5aa423e0a977ba99447f33
+ sha1sums = d314df1acdd30d9297aaf7b2c1956908f0152d2c
pkgname = i3-wm-iconpatch
diff --git a/PKGBUILD b/PKGBUILD
index 868bb05236ec..aca47b258c8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=i3-wm-iconpatch
_pkgsourcename=i3
-pkgver=4.16.1
+pkgver=4.17.1
pkgrel=1
pkgdesc='An improved dynamic tiling window manager (with titlebar icon patch)'
arch=('i686' 'x86_64')
@@ -29,11 +29,9 @@ options=('docs' '!strip')
source=("http://i3wm.org/downloads/${_pkgsourcename}-${pkgver}.tar.bz2"
"http://i3wm.org/downloads/${_pkgsourcename}-${pkgver}.tar.bz2.asc"
"iconsupport.patch")
-sha1sums=(
- '95607b8e09bdf5d18032b2ec391cb1000efcdf5a'
- 'SKIP'
- '2ccc24022d4bbf1b1f5aa423e0a977ba99447f33'
-)
+sha1sums=('1834ce349a2aea2fbb0d44d9ed820fa9e1a394ab'
+ 'SKIP'
+ 'd314df1acdd30d9297aaf7b2c1956908f0152d2c')
validpgpkeys=('424E14D703E7C6D43D9D6F364E7160ED4AC8EE1D') # Michael Stapelberg
prepare() {
diff --git a/iconsupport.patch b/iconsupport.patch
index 1e3096df85b4..f6df6e4cbb24 100644
--- a/iconsupport.patch
+++ b/iconsupport.patch
@@ -10,22 +10,21 @@ index b65a81d..df56fd3 100644
xmacro(WM_PROTOCOLS)
xmacro(WM_DELETE_WINDOW)
xmacro(UTF8_STRING)
-diff --git a/include/data.h b/include/data.h
-index f55e003..d7e22a3 100644
--- a/include/data.h
+++ b/include/data.h
-@@ -483,6 +483,11 @@ struct Window {
+@@ -483,7 +483,12 @@ struct Window {
/* aspect ratio from WM_NORMAL_HINTS (MPlayer uses this for example) */
- double aspect_ratio;
+ double min_aspect_ratio;
+ double max_aspect_ratio;
+
+ /** Window icon, as array of ARGB pixels */
+ uint32_t* icon;
+ int icon_width;
+ int icon_height;
- };
- /**
+ /** The window has a nonrectangular shape. */
+ bool shaped;
diff --git a/include/libi3.h b/include/libi3.h
index 790baba..cc88ee7 100644
--- a/include/libi3.h
@@ -42,8 +41,6 @@ index 790baba..cc88ee7 100644
/**
* Draws a filled rectangle.
* This function is a convenience wrapper and takes care of flushing the
-diff --git a/include/window.h b/include/window.h
-index 77e3f48..894ee9f 100644
--- a/include/window.h
+++ b/include/window.h
@@ -89,3 +89,9 @@ void window_update_hints(i3Window *win, xcb_get_property_reply_t *prop, bool *ur
@@ -56,8 +53,6 @@ index 77e3f48..894ee9f 100644
+ *
+ */
+void window_update_icon(i3Window *win, xcb_get_property_reply_t *prop);
-diff --git a/libi3/draw_util.c b/libi3/draw_util.c
-index f88360d..59a9d8e 100644
--- a/libi3/draw_util.c
+++ b/libi3/draw_util.c
@@ -140,6 +140,42 @@ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_
@@ -103,8 +98,6 @@ index f88360d..59a9d8e 100644
/*
* Draws a filled rectangle.
* This function is a convenience wrapper and takes care of flushing the
-diff --git a/src/handlers.c b/src/handlers.c
-index b967791..efab679 100644
--- a/src/handlers.c
+++ b/src/handlers.c
@@ -1392,6 +1392,19 @@ static bool handle_strut_partial_change(void *data, xcb_connection_t *conn, uint
@@ -145,8 +138,6 @@ index b967791..efab679 100644
}
static void property_notify(uint8_t state, xcb_window_t window, xcb_atom_t atom) {
-diff --git a/src/manage.c b/src/manage.c
-index c4706b0..4e240d7 100644
--- a/src/manage.c
+++ b/src/manage.c
@@ -91,6 +91,8 @@ void manage_window(xcb_window_t window, xcb_get_window_attributes_cookie_t cooki
@@ -174,17 +165,6 @@ index c4706b0..4e240d7 100644
window_update_leader(cwindow, xcb_get_property_reply(conn, leader_cookie, NULL));
window_update_transient_for(cwindow, xcb_get_property_reply(conn, transient_cookie, NULL));
window_update_strut_partial(cwindow, xcb_get_property_reply(conn, strut_cookie, NULL));
-@@ -185,6 +189,8 @@ void manage_window(xcb_window_t window, xcb_get_window_attributes_cookie_t cooki
- window_update_hints(cwindow, xcb_get_property_reply(conn, wm_hints_cookie, NULL), &urgency_hint);
- border_style_t motif_border_style = BS_NORMAL;
- window_update_motif_hints(cwindow, xcb_get_property_reply(conn, motif_wm_hints_cookie, NULL), &motif_border_style);
-+
-+
- xcb_size_hints_t wm_size_hints;
- if (!xcb_icccm_get_wm_size_hints_reply(conn, wm_normal_hints_cookie, &wm_size_hints, NULL))
- memset(&wm_size_hints, '\0', sizeof(xcb_size_hints_t));
-diff --git a/src/window.c b/src/window.c
-index 6128255..797be6a 100644
--- a/src/window.c
+++ b/src/window.c
@@ -17,6 +17,7 @@ void window_free(i3Window *win) {
@@ -287,8 +267,6 @@ index 6128255..797be6a 100644
+
+ FREE(prop);
+}
-diff --git a/src/x.c b/src/x.c
-index 267372f..51ea062 100644
--- a/src/x.c
+++ b/src/x.c
@@ -576,11 +576,35 @@ void x_draw_decoration(Con *con) {