summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-11-13 22:56:49 -0800
committerxiota2023-11-13 22:57:28 -0800
commit9048448f12122c78b4ec9674acbc44039a213b78 (patch)
treebd6336ce1a054f960beea25e72d9088374c1138e
parent8cb7f0cd624946e85bac8dff9e33d434b01f60fa (diff)
downloadaur-9048448f12122c78b4ec9674acbc44039a213b78.tar.gz
update packaging
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD50
3 files changed, 36 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 131eb3c60fa8..89c9936e8650 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = revelation
- pkgdesc = A password manager for the GNOME desktop
+ pkgdesc = Password manager for the GNOME desktop
pkgver = 0.5.5
- pkgrel = 1
- url = http://revelation.olasagasti.info/
+ pkgrel = 2
+ url = https://github.com/mikelolasagasti/revelation
arch = x86_64
license = GPL
makedepends = gobject-introspection
makedepends = meson
depends = gtk3
depends = libpwquality
+ depends = python-defusedxml
depends = python-gobject
depends = python-pycryptodomex
- depends = python-defusedxml
source = https://github.com/mikelolasagasti/revelation/releases/download/revelation-0.5.5/revelation-0.5.5.tar.xz
sha256sums = a20c4191595466dc90b90b0f7c4615a599974327152a4d2af87f506134ddce8f
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 606355534255..87f6ed5b82e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,41 @@
-# Maintainer: Michał Lisowski <lisu@riseup.net>
+# Maintainer:
+# Contributor: Michał Lisowski <lisu@riseup.net>
# Contributor: Thomas Hebb <tommyhebb@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
+
pkgname=revelation
pkgver=0.5.5
-pkgrel=1
-pkgdesc="A password manager for the GNOME desktop"
-arch=('x86_64')
+pkgrel=2
+pkgdesc="Password manager for the GNOME desktop"
+url="https://github.com/mikelolasagasti/revelation"
license=('GPL')
-makedepends=('gobject-introspection' 'meson')
-depends=('gtk3' 'libpwquality' 'python-gobject' 'python-pycryptodomex' 'python-defusedxml')
-url="http://revelation.olasagasti.info/"
-source=("https://github.com/mikelolasagasti/revelation/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.xz")
-sha256sums=('a20c4191595466dc90b90b0f7c4615a599974327152a4d2af87f506134ddce8f')
+arch=('x86_64')
-prepare() {
- cd "${pkgname}-${pkgver}"
+depends=(
+ gtk3
+ libpwquality
+ python-defusedxml
+ python-gobject
+ python-pycryptodomex
+)
+makedepends=(
+ gobject-introspection
+ meson
+)
- sed -i '/ appdata,/d' data/meson.build
-}
+_pkgsrc="$pkgname-$pkgver"
+_pkgext="tar.xz"
+source=(
+ "$url/releases/download/$_pkgsrc/$_pkgsrc.$_pkgext")
+sha256sums=(
+ 'a20c4191595466dc90b90b0f7c4615a599974327152a4d2af87f506134ddce8f'
+)
build() {
- cd "${pkgname}-${pkgver}"
-
- meson _build
- meson configure --prefix=/usr _build
+ arch-meson "$_pkgsrc" build
+ meson compile -C build
}
package() {
- cd "${pkgname}-${pkgver}"
-
- cd _build
- DESTDIR="${pkgdir}" meson install
+ meson install -C build --destdir "$pkgdir"
}
-