summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Fanninger2016-07-21 12:46:36 +0200
committerThomas Fanninger2016-07-21 12:46:36 +0200
commit904e7c4f47191e9558cfe26c4d4455a95a0e136d (patch)
treef2dd2458e8cb3bba5ead8193bd2787c35911e49d
parent2522d4c6af7e12c7446e39e36222a9292dad013c (diff)
downloadaur-904e7c4f47191e9558cfe26c4d4455a95a0e136d.tar.gz
New maintainer, correct issue
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
-rw-r--r--log4cxx-0.10.0-missing_includes.patch2
-rw-r--r--log4cxx-0.10.0-narrowing-fixes-from-upstream.patch117
4 files changed, 140 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5faab1b8a82..5465ac6d2476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
+# Generated by mksrcinfo v8
+# Thu Jul 21 10:46:13 UTC 2016
pkgbase = log4cxx
pkgdesc = A C++ port of Log4j
pkgver = 0.10.0
- pkgrel = 3
+ pkgrel = 4
url = http://logging.apache.org/log4cxx
- arch = i686
- arch = x86_64
+ arch = any
license = Apache
makedepends = autoconf
makedepends = automake
@@ -15,10 +16,14 @@ pkgbase = log4cxx
makedepends = sed
depends = apr-util
depends = libxml2
+ provides = log4cxx
+ conflicts = log4cxx-svn
source = http://archive.apache.org/dist/logging/log4cxx/0.10.0/apache-log4cxx-0.10.0.tar.gz
source = log4cxx-0.10.0-missing_includes.patch
- md5sums = b30ffb8da3665178e68940ff7a61084c
- md5sums = dfa17719a57b19f12cbef94419a2aac8
+ source = log4cxx-0.10.0-narrowing-fixes-from-upstream.patch
+ sha512sums = 1c34d80983db5648bc4582ddcf6b4fdefdc6594c2769f95235f5441cd6d03cf279cc8f365e9a687085b113f79ebac9d7d33a54b6aa3b3b808c0e1a56a15ffa37
+ sha512sums = 14fa0b19516171cbbe2c6220816819fc52cf8f3b3ded5d71966e2f4a71bda9ce1ed8fe7e57745a835e6ac5558631916ed9824d09ec7469d84c7bf99fb4946304
+ sha512sums = 15b692b37961adbc808e4c10d2719483502f3ac060ee5be248832d4e2a2f76f7d9e120ea9a6bf908230cf230a893964040e54415cca35a12e576d0a5ab1f4176
pkgname = log4cxx
diff --git a/PKGBUILD b/PKGBUILD
index f60d4c937ae4..d6d4bf5e7617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
pkgname=log4cxx
pkgver=0.10.0
-pkgrel=3
+pkgrel=4
pkgdesc="A C++ port of Log4j"
url="http://logging.apache.org/log4cxx"
license=("Apache")
depends=('apr-util' 'libxml2')
-arch=('i686' 'x86_64')
+arch=('any')
makedepends=('autoconf' 'automake' 'libtool' 'patch' 'zip' 'gzip' 'sed')
+provides=('log4cxx')
+conflicts=('log4cxx-svn')
-source=(http://archive.apache.org/dist/logging/$pkgname/$pkgver/apache-$pkgname-$pkgver.tar.gz
- log4cxx-0.10.0-missing_includes.patch)
-md5sums=('b30ffb8da3665178e68940ff7a61084c'
- 'dfa17719a57b19f12cbef94419a2aac8')
+source=("http://archive.apache.org/dist/logging/$pkgname/$pkgver/apache-$pkgname-$pkgver.tar.gz"
+ 'log4cxx-0.10.0-missing_includes.patch'
+ 'log4cxx-0.10.0-narrowing-fixes-from-upstream.patch')
+sha512sums=('1c34d80983db5648bc4582ddcf6b4fdefdc6594c2769f95235f5441cd6d03cf279cc8f365e9a687085b113f79ebac9d7d33a54b6aa3b3b808c0e1a56a15ffa37'
+ '14fa0b19516171cbbe2c6220816819fc52cf8f3b3ded5d71966e2f4a71bda9ce1ed8fe7e57745a835e6ac5558631916ed9824d09ec7469d84c7bf99fb4946304'
+ '15b692b37961adbc808e4c10d2719483502f3ac060ee5be248832d4e2a2f76f7d9e120ea9a6bf908230cf230a893964040e54415cca35a12e576d0a5ab1f4176')
build() {
cd "$srcdir/apache-$pkgname-$pkgver"
patch -p1 < $startdir/log4cxx-0.10.0-missing_includes.patch
+ patch -p1 < $startdir/log4cxx-0.10.0-narrowing-fixes-from-upstream.patch
+ #./autogen.sh
./configure --prefix=/usr --disable-static
make
}
diff --git a/log4cxx-0.10.0-missing_includes.patch b/log4cxx-0.10.0-missing_includes.patch
index 9f3534ccc7e6..6834648d09a8 100644
--- a/log4cxx-0.10.0-missing_includes.patch
+++ b/log4cxx-0.10.0-missing_includes.patch
@@ -35,4 +35,4 @@ diff -Naur apache-log4cxx-0.10.0.orig/src/main/cpp/socketoutputstream.cpp apache
+#include <cstring>
+
using namespace log4cxx;
- using namespace log4cxx::helpers;
+ using namespace log4cxx::helpers; \ No newline at end of file
diff --git a/log4cxx-0.10.0-narrowing-fixes-from-upstream.patch b/log4cxx-0.10.0-narrowing-fixes-from-upstream.patch
new file mode 100644
index 000000000000..e583e7661d1d
--- /dev/null
+++ b/log4cxx-0.10.0-narrowing-fixes-from-upstream.patch
@@ -0,0 +1,117 @@
+diff --git a/src/main/cpp/locationinfo.cpp b/src/main/cpp/locationinfo.cpp
+index e76ea29..bd22a1d 100644
+--- a/src/main/cpp/locationinfo.cpp
++++ b/src/main/cpp/locationinfo.cpp
+@@ -149,18 +149,21 @@ void LocationInfo::write(ObjectOutputStream& os, Pool& p) const {
+ os.writeNull(p);
+ } else {
+ char prolog[] = {
+- 0x72, 0x00, 0x21, 0x6F, 0x72, 0x67, 0x2E,
+- 0x61, 0x70, 0x61, 0x63, 0x68, 0x65, 0x2E, 0x6C,
+- 0x6F, 0x67, 0x34, 0x6A, 0x2E, 0x73, 0x70, 0x69,
+- 0x2E, 0x4C, 0x6F, 0x63, 0x61, 0x74, 0x69, 0x6F,
+- 0x6E, 0x49, 0x6E, 0x66, 0x6F, 0xED, 0x99, 0xBB,
+- 0xE1, 0x4A, 0x91, 0xA5, 0x7C, 0x02, 0x00, 0x01,
+- 0x4C, 0x00, 0x08, 0x66, 0x75, 0x6C, 0x6C, 0x49,
+- 0x6E, 0x66, 0x6F,
+- 0x74, 0x00, 0x12, 0x4C, 0x6A,
+- 0x61, 0x76, 0x61, 0x2F, 0x6C, 0x61, 0x6E, 0x67,
+- 0x2F, 0x53, 0x74, 0x72, 0x69, 0x6E, 0x67, 0x3B,
+- 0x78, 0x70 };
++ 0x72,
++ 0x00,
++ 0x21, 0x6F, 0x72, 0x67, 0x2E, 0x61, 0x70, 0x61, 0x63, 0x68, 0x65, 0x2E,
++ 0x6C, 0x6F, 0x67, 0x34, 0x6A, 0x2E, 0x73, 0x70, 0x69, 0x2E, 0x4C, 0x6F,
++ 0x63, 0x61, 0x74, 0x69, 0x6F, 0x6E, 0x49, 0x6E, 0x66, 0x6F, static_cast<char>(0xED),
++ static_cast<char>(0x99), static_cast<char>(0xBB), static_cast<char>(0xE1),
++ 0x4A, static_cast<char>(0x91), static_cast<char>(0xA5), 0x7C, 0x02,
++ 0x00,
++ 0x01, 0x4C,
++ 0x00,
++ 0x08, 0x66, 0x75, 0x6C, 0x6C, 0x49, 0x6E, 0x66, 0x6F, 0x74,
++ 0x00,
++ 0x12, 0x4C, 0x6A, 0x61, 0x76, 0x61, 0x2F, 0x6C, 0x61, 0x6E, 0x67, 0x2F,
++ 0x53, 0x74, 0x72, 0x69, 0x6E, 0x67, 0x3B, 0x78, 0x70
++ };
+ os.writeProlog("org.apache.log4j.spi.LocationInfo", 2, prolog, sizeof(prolog), p);
+ char* line = p.itoa(lineNumber);
+ //
+diff --git a/src/main/cpp/loggingevent.cpp b/src/main/cpp/loggingevent.cpp
+index 1c0d4be..edbf40b 100644
+--- a/src/main/cpp/loggingevent.cpp
++++ b/src/main/cpp/loggingevent.cpp
+@@ -242,7 +242,7 @@ void LoggingEvent::writeProlog(ObjectOutputStream& os, Pool& p) {
+ 0x68, 0x65, 0x2E, 0x6C, 0x6F, 0x67, 0x34, 0x6A,
+ 0x2E, 0x73, 0x70, 0x69, 0x2E, 0x4C, 0x6F, 0x67,
+ 0x67, 0x69, 0x6E, 0x67, 0x45, 0x76, 0x65, 0x6E,
+- 0x74, 0xF3, 0xF2, 0xB9, 0x23, 0x74, 0x0B, 0xB5,
++ 0x74, static_cast<char>(0xF3), static_cast<char>(0xF2), static_cast<char>(0xB9), 0x23, 0x74, 0x0B, static_cast<char>(0xB5),
+ 0x3F, 0x03, 0x00, 0x0A, 0x5A, 0x00, 0x15, 0x6D,
+ 0x64, 0x63, 0x43, 0x6F, 0x70, 0x79, 0x4C, 0x6F,
+ 0x6F, 0x6B, 0x75, 0x70, 0x52, 0x65, 0x71, 0x75,
+diff --git a/src/main/cpp/objectoutputstream.cpp b/src/main/cpp/objectoutputstream.cpp
+index 7cd696b..5442420 100644
+--- a/src/main/cpp/objectoutputstream.cpp
++++ b/src/main/cpp/objectoutputstream.cpp
+@@ -36,7 +36,7 @@ ObjectOutputStream::ObjectOutputStream(OutputStreamPtr outputStream, Pool& p)
+ objectHandle(0x7E0000),
+ classDescriptions(new ClassDescriptionMap())
+ {
+- char start[] = { 0xAC, 0xED, 0x00, 0x05 };
++ char start[] = { static_cast<char>(0xAC), static_cast<char>(0xED), 0x00, 0x05 };
+ ByteBuffer buf(start, sizeof(start));
+ os->write(buf, p);
+ }
+@@ -81,15 +81,15 @@ void ObjectOutputStream::writeObject(const MDC::Map& val, Pool& p) {
+ //
+ // TC_OBJECT and the classDesc for java.util.Hashtable
+ //
+- char prolog[] = {
+- 0x72, 0x00, 0x13, 0x6A, 0x61, 0x76, 0x61,
+- 0x2E, 0x75, 0x74, 0x69, 0x6C, 0x2E, 0x48, 0x61,
+- 0x73, 0x68, 0x74, 0x61, 0x62, 0x6C, 0x65, 0x13,
+- 0xBB, 0x0F, 0x25, 0x21, 0x4A, 0xE4, 0xB8, 0x03,
+- 0x00, 0x02, 0x46, 0x00, 0x0A, 0x6C, 0x6F, 0x61,
+- 0x64, 0x46, 0x61, 0x63, 0x74, 0x6F, 0x72, 0x49,
+- 0x00, 0x09, 0x74, 0x68, 0x72, 0x65, 0x73, 0x68,
+- 0x6F, 0x6C, 0x64, 0x78, 0x70 };
++ char prolog[] = {
++ 0x72, 0x00, 0x13, 0x6A, 0x61, 0x76, 0x61,
++ 0x2E, 0x75, 0x74, 0x69, 0x6C, 0x2E, 0x48, 0x61,
++ 0x73, 0x68, 0x74, 0x61, 0x62, 0x6C, 0x65, 0x13,
++ static_cast<char>(0xBB), 0x0F, 0x25, 0x21, 0x4A, static_cast<char>(0xE4), static_cast<char>(0xB8), 0x03,
++ 0x00, 0x02, 0x46, 0x00, 0x0A, 0x6C, 0x6F, 0x61,
++ 0x64, 0x46, 0x61, 0x63, 0x74, 0x6F, 0x72, 0x49,
++ 0x00, 0x09, 0x74, 0x68, 0x72, 0x65, 0x73, 0x68,
++ 0x6F, 0x6C, 0x64, 0x78, 0x70 };
+ writeProlog("java.util.Hashtable", 1, prolog, sizeof(prolog), p);
+ //
+ // loadFactor = 0.75, threshold = 5, blockdata start, buckets.size = 7
+diff --git a/src/test/cpp/xml/domtestcase.cpp b/src/test/cpp/xml/domtestcase.cpp
+index a500628..29d67dd 100644
+--- a/src/test/cpp/xml/domtestcase.cpp
++++ b/src/test/cpp/xml/domtestcase.cpp
+@@ -190,9 +190,9 @@ public:
+ DOMConfigurator::configure(LOG4CXX_TEST_STR("input/xml/DOMTestCase3.xml"));
+ LOG4CXX_INFO(logger, "File name is expected to end with a superscript 3");
+ #if LOG4CXX_LOGCHAR_IS_UTF8
+- const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, 0xC2, 0xB3, 0 };
++ const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, static_cast<logchar>(0xC2), static_cast<logchar>(0xB3), 0 };
+ #else
+- const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, 0xB3, 0 };
++ const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, static_cast<logchar>(0xB3), 0 };
+ #endif
+ File file;
+ file.setPath(fname);
+@@ -209,9 +209,9 @@ public:
+ DOMConfigurator::configure(LOG4CXX_TEST_STR("input/xml/DOMTestCase4.xml"));
+ LOG4CXX_INFO(logger, "File name is expected to end with an ideographic 4");
+ #if LOG4CXX_LOGCHAR_IS_UTF8
+- const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, 0xE3, 0x86, 0x95, 0 };
++ const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, static_cast<logchar>(0xE3), static_cast<logchar>(0x86), static_cast<logchar>(0x95), 0 };
+ #else
+- const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, 0x3195, 0 };
++ const logchar fname[] = { 0x6F, 0x75, 0x74, 0x70, 0x75, 0x74, 0x2F, 0x64, 0x6F, 0x6D, static_cast<logchar>(0x3195), 0 };
+ #endif
+ File file;
+ file.setPath(fname); \ No newline at end of file