summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjgmdev2024-01-12 16:51:12 -0400
committerjgmdev2024-01-12 16:51:12 -0400
commit90778f98cafa28f4927ccf7a5914f89741c11c06 (patch)
tree0246b0ab2f9222c2ad445ee04d7b3d10f086aeaa
parentd4a3afd232459a686bc4375d544ad56ab86054f9 (diff)
downloadaur-90778f98cafa28f4927ccf7a5914f89741c11c06.tar.gz
Updated to latest version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
-rw-r--r--auitabart.patch34
-rw-r--r--md5hh-cinttypes.patch11
-rw-r--r--tinyxml2-no-install.patch25
5 files changed, 39 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42ac1fe1395f..66b537cfe17b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxformbuilder
pkgdesc = RAD tool for wxWidgets GUI design
- pkgver = 3.10.1
- pkgrel = 3
+ pkgver = 4.0.0
+ pkgrel = 1
url = https://github.com/wxFormBuilder/wxFormBuilder
arch = i686
arch = x86_64
@@ -14,11 +14,9 @@ pkgbase = wxformbuilder
conflicts = wxformbuilder
conflicts = wxformbuilder-svn
conflicts = wxformbuilder-git
- source = https://github.com/wxFormBuilder/wxFormBuilder/releases/download/v3.10.1/wxFormBuilder-3.10.1-source-full.tar.gz
- source = auitabart.patch
- source = md5hh-cinttypes.patch
- sha512sums = de8d51b8907529fd882bcd1908fbce49381f0e75bfb0ea00b319d856d835769739e03b829b9ede5d1439513fba1e42bbc247e51cde54f89dc50efa1b0bc43a4c
- sha512sums = ecf3df7d10852ea5137713ea5568cb42601e3bd2047d9a020288617cc503d42027de414bbd739d16e695354e2822361a6510d2a14f93b88ec4d433dc680fc16f
- sha512sums = bbf684fe66abdb40c1845e0634d583726af5c77731b2f48662b929eb0f679704e999bc02b03efc2c1f6276131f8826bc646f8a33e90e58042074560e8432aaa4
+ source = https://github.com/wxFormBuilder/wxFormBuilder/releases/download/v4.0.0/wxFormBuilder-4.0.0-source-full.tar.gz
+ source = tinyxml2-no-install.patch
+ sha512sums = fd50f66584a6b03d7cb2281d20649fb39b2d4923dadfa44bc244732d524a08483ed9c7a97fbf02d613b7a1e494858b9ea0d2d13a554bcca2dab277cfa892ecc1
+ sha512sums = cb941a55d67104f68a3b1ab84f19c5016d96ba52efb9ea7755be33f52af6c5ce8fba36f25e8f10d0ddd38ed9842192a6ef55a9de2b54b3428aed4e360653b7c0
pkgname = wxformbuilder
diff --git a/PKGBUILD b/PKGBUILD
index b840d8c5162f..e0348f21f432 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
+# Maintainer: jgmdev <jgmdev at gmail dot com>
# Maintainer: redtide <redtid3 at gmail dot com>
# Maintainer: Antonio O. <antonio.mx.9605 at gmail dot com>
_prjname=wxFormBuilder
pkgname=wxformbuilder
-pkgver=3.10.1
-pkgrel=3
+pkgver=4.0.0
+pkgrel=1
pkgdesc="RAD tool for wxWidgets GUI design"
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/wxFormBuilder/wxFormBuilder"
@@ -14,19 +15,16 @@ conflicts=('wxformbuilder' 'wxformbuilder-svn' 'wxformbuilder-git')
depends=('wxwidgets-gtk3' 'boost')
makedepends=('cmake')
source=(
- "https://github.com/wxFormBuilder/wxFormBuilder/releases/download/v3.10.1/wxFormBuilder-3.10.1-source-full.tar.gz"
- "auitabart.patch"
- "md5hh-cinttypes.patch"
+ "https://github.com/wxFormBuilder/wxFormBuilder/releases/download/v${pkgver}/wxFormBuilder-${pkgver}-source-full.tar.gz"
+ "tinyxml2-no-install.patch"
)
sha512sums=(
- "de8d51b8907529fd882bcd1908fbce49381f0e75bfb0ea00b319d856d835769739e03b829b9ede5d1439513fba1e42bbc247e51cde54f89dc50efa1b0bc43a4c"
- "ecf3df7d10852ea5137713ea5568cb42601e3bd2047d9a020288617cc503d42027de414bbd739d16e695354e2822361a6510d2a14f93b88ec4d433dc680fc16f"
- "bbf684fe66abdb40c1845e0634d583726af5c77731b2f48662b929eb0f679704e999bc02b03efc2c1f6276131f8826bc646f8a33e90e58042074560e8432aaa4"
+ "fd50f66584a6b03d7cb2281d20649fb39b2d4923dadfa44bc244732d524a08483ed9c7a97fbf02d613b7a1e494858b9ea0d2d13a554bcca2dab277cfa892ecc1"
+ "cb941a55d67104f68a3b1ab84f19c5016d96ba52efb9ea7755be33f52af6c5ce8fba36f25e8f10d0ddd38ed9842192a6ef55a9de2b54b3428aed4e360653b7c0"
)
prepare() {
cd "${_prjname}-${pkgver}"
- patch --forward --strip=1 --input="${srcdir}/auitabart.patch"
- patch --forward --strip=1 --input="${srcdir}/md5hh-cinttypes.patch"
+ patch --forward --strip=1 --input="${srcdir}/tinyxml2-no-install.patch"
}
build() {
cd "${_prjname}-${pkgver}"
diff --git a/auitabart.patch b/auitabart.patch
deleted file mode 100644
index aa5f8732a459..000000000000
--- a/auitabart.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --unified --recursive --text a/src/rad/auitabart.h b/src/rad/auitabart.h
---- a/src/rad/auitabart.h 2021-10-22 18:19:37.000000000 +0200
-+++ b/src/rad/auitabart.h 2022-08-13 11:32:26.550275012 +0200
-@@ -3,14 +3,22 @@
-
- #include <wx/aui/auibook.h>
-
--class AuiTabArt : public wxAuiGenericTabArt {
-+class AuiTabArt : public wxAuiGenericTabArt
-+{
- public:
-- wxSize GetTabSize(wxDC& dc, wxWindow* wnd, const wxString& caption, const wxBitmap& bitmap,
-- bool active, int close_button_state, int* x_extent) override {
-- return wxAuiGenericTabArt::GetTabSize(dc, wnd, caption, bitmap, active, close_button_state,
-- x_extent) +
-- wxSize(0, 2);
-- }
--};
-+#if wxCHECK_VERSION(3, 1, 6)
-+ wxSize GetTabSize(
-+ wxDC& dc, wxWindow* wnd, const wxString& caption, const wxBitmapBundle& bitmap, bool active,
-+ int close_button_state, int* x_extent) override{
-+#else
-+ wxSize GetTabSize(
-+ wxDC& dc, wxWindow* wnd, const wxString& caption, const wxBitmap& bitmap, bool active, int close_button_state,
-+ int* x_extent) override
-+ {
-+#endif
-+ return wxAuiGenericTabArt::GetTabSize(dc, wnd, caption, bitmap, active, close_button_state, x_extent) +
-+ wxSize(0, 2);
-+}
-+};
-
- #endif // __AUITABART_H__
diff --git a/md5hh-cinttypes.patch b/md5hh-cinttypes.patch
deleted file mode 100644
index 6a58c5292d84..000000000000
--- a/md5hh-cinttypes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --unified --recursive --text package.orig/src/md5/md5.hh package.new/src/md5/md5.hh
---- package.orig/src/md5/md5.hh 2021-10-22 18:19:37.000000000 +0200
-+++ package.new/src/md5/md5.hh 2023-09-14 10:58:38.273030750 +0200
-@@ -40,6 +40,7 @@
- */
- #pragma once
-
-+#include <cinttypes>
- #include <cstdio>
- #include <istream>
-
diff --git a/tinyxml2-no-install.patch b/tinyxml2-no-install.patch
new file mode 100644
index 000000000000..3c5be8f74398
--- /dev/null
+++ b/tinyxml2-no-install.patch
@@ -0,0 +1,25 @@
+From a75305af33d8113e0e2914c7f50e61d3f3f79746 Mon Sep 17 00:00:00 2001
+From: Steffen Olszewski <steffen.olszewski@gero-mess.de>
+Date: Wed, 13 Dec 2023 21:43:00 +0100
+Subject: [PATCH] Prevent installation of TinyXML2 development files
+
+Simply exclude the library from the ALL target for now.
+If the library gets build as shared library, the runtime component
+needs to be installed explicit.
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ef78e5a..7fdf2e1e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -104,7 +104,7 @@ add_subdirectory(sdk)
+ add_subdirectory(third_party/md5)
+ add_subdirectory(third_party/stack_trace)
+ stash_variable(BUILD_SHARED_LIBS ${WXFB_TINYXML2_SHARED})
+-add_subdirectory(third_party/tinyxml2)
++add_subdirectory(third_party/tinyxml2 EXCLUDE_FROM_ALL)
+ restore_variable(BUILD_SHARED_LIBS)
+
+ if(NOT WXFB_BUILD_PLUGIN_HOST)