summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2024-03-19 08:46:35 +0100
committerAlad Wenter2024-03-19 08:46:35 +0100
commit9080d56239f0297cf9cd7ab2441dc43312ea649f (patch)
tree13406222361ce9ad3ea800d472a93cc450e36a02
parent77ea360a1f6e57f4dc2aba7cbc69cd82d36568fd (diff)
downloadaur-9080d56239f0297cf9cd7ab2441dc43312ea649f.tar.gz
aurutils: v19
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--aurutils.changelog36
3 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4d47a4bf154..f2fc5261b24c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aurutils
pkgdesc = helper tools for the arch user repository
- pkgver = 18.5
+ pkgver = 19
pkgrel = 1
url = https://github.com/AladW/aurutils
install = aurutils.install
@@ -21,7 +21,7 @@ pkgbase = aurutils
optdepends = bat: view-delta example script
optdepends = git-delta: view-delta example script
optdepends = python-srcinfo: sync-rebuild example script
- source = aurutils-18.5.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/18.5.tar.gz
- sha256sums = b2a5a9dcd9b65acce9db9924293c6ed36f14d559f9337b75b0281503c2c6a118
+ source = aurutils-19.tar.gz::https://github.com/AladW/aurutils/archive/refs/tags/19.tar.gz
+ sha256sums = d152670c0a47864fd2ec7dfa63e6cc628dad859e0e0891dd1f5ba5df70478a74
pkgname = aurutils
diff --git a/PKGBUILD b/PKGBUILD
index 8b2d9fb7ef21..7b5e45250604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Co-Maintainer: zoorat <zoorat [at] protonmail [dot] com>
pkgname=aurutils
-pkgver=18.5
+pkgver=19
pkgrel=1
pkgdesc='helper tools for the arch user repository'
url='https://github.com/AladW/aurutils'
@@ -12,7 +12,7 @@ license=('custom:ISC')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
changelog=aurutils.changelog
install=aurutils.install
-sha256sums=('b2a5a9dcd9b65acce9db9924293c6ed36f14d559f9337b75b0281503c2c6a118')
+sha256sums=('d152670c0a47864fd2ec7dfa63e6cc628dad859e0e0891dd1f5ba5df70478a74')
depends=('git' 'pacutils' 'curl' 'perl' 'perl-json-xs' 'bash')
optdepends=('bash-completion: bash completion'
'zsh: zsh completion'
@@ -30,5 +30,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make PREFIX=/usr ETCDIR=/etc DESTDIR="$pkgdir" install
+ make AURUTILS_VERSION="$pkgver" PREFIX=/usr ETCDIR=/etc DESTDIR="$pkgdir" install
}
diff --git a/aurutils.changelog b/aurutils.changelog
index c2dc7c455937..d87eb7c6b71d 100644
--- a/aurutils.changelog
+++ b/aurutils.changelog
@@ -1,3 +1,39 @@
+## 19
+
+* `aur-build`
+ + add `--cleanbuild`
+ + do not shell quote `--status` paths
+ + early check for buildscript
+
+* `aur-chroot`
+ + do not shell quote `--status` paths
+
+* `aur-depends`
+ + only include `Self` targets for command-line arguments (`--table`, #1136)
+ + verify dependency version requirements (`--verify`)
+
+* `aur-graph`
+ + prevent unwanted matches in certain URLs (#1134)
+
+* `aur-repo`
+ + add `-m` / `--missing`
+ + add `--ignore`, `--ignore-by`
+ + do not shell quote `--status` paths
+ + fix invalid output with `--json --search` (#1126)
+
+* `aur-sync`
+ + document `aur-view` options
+ + detect local repositories with `--chroot` configuration (#1135)
+ + add `--clean` / `-C`, `--cleanbuild`
+ - default build command changed to `aur build --syncdeps`
+ + add `aur-sync--filter` helper (#1136, #1140)
+
+* `aur(1)`
+ + use `git-clean -ixd` to clean directories with `aur-gc`
+
+* `perl`
+ + add `Depends.pm`, `Repo.pm`
+
## 18.5
* `aur-repo`