summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Cassani2019-06-06 11:58:51 +0200
committerFederico Cassani2019-06-06 11:58:51 +0200
commit90879dc0e13e636766e95766dc4466cbe390b803 (patch)
treeaeda9c2eed40a2dd7c586ba4b8418932563e0e84
downloadaur-90879dc0e13e636766e95766dc4466cbe390b803.tar.gz
INIT version 0.4.9
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD24
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cf917225f39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-talos
+ pkgdesc = Talos radically changes the ordinary Keras workflow by fullyautomating hyperparameter tuning and model evaluation. Talos exposes Keras functionality entirely and there is no new syntax or templates to learn.
+ pkgver = 0.4.9
+ pkgrel = 1
+ url = https://github.com/autonomio/talos/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-keras
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-scikit-learn
+ depends = python-tqdm
+ depends = python-requests
+ depends = python-wrangle
+ depends = python-chances
+ depends = python-astetik
+ depends = python-kerasplotlib
+ source = https://files.pythonhosted.org/packages/74/26/c44a51af579835c873e878b99c68fcba08107cdfc22d72ac4ecbc027f158/talos-0.4.9.tar.gz
+ sha256sums = 623f0bfe33f1429453913cf64eabbf5cd34d3147781013f8824fb3888d6ad8fd
+
+pkgname = python-talos
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6b4a8512010
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,19 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35dc891ac05e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Federico Cassani <federico dot cassani at outlook dot com>
+
+pkgname="python-talos"
+_pkgname="talos"
+pkgver=0.4.9
+pkgrel=1
+pkgdesc="Talos radically changes the ordinary Keras workflow by fullyautomating hyperparameter tuning and model evaluation. Talos exposes Keras functionality entirely and there is no new syntax or templates to learn."
+arch=('any')
+url="https://github.com/autonomio/talos/"
+license=('MIT')
+depends=('python' 'python-keras' 'python-numpy' 'python-pandas' 'python-scikit-learn' 'python-tqdm' 'python-requests' 'python-wrangle' 'python-chances' 'python-astetik' 'python-kerasplotlib')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/74/26/c44a51af579835c873e878b99c68fcba08107cdfc22d72ac4ecbc027f158/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('623f0bfe33f1429453913cf64eabbf5cd34d3147781013f8824fb3888d6ad8fd')
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}