summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-04-25 16:08:56 -0400
committerAlex Whitt2017-04-25 16:08:56 -0400
commit90db0ca8ff214f99210c7826385083ffedac706f (patch)
tree6c4ddb3dca0b6d8138d6e828d48515525b658b4b
downloadaur-90db0ca8ff214f99210c7826385083ffedac706f.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec033f90e0e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Apr 25 20:08:35 UTC 2017
+pkgbase = emacs-all-the-icons
+ pkgdesc = A utility package to collect various Icon Fonts and propertize them within Emacs.
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/domtronn/all-the-icons.el
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = emacs
+ depends = emacs-font-lock-plus
+ provides = emacs-all-the-icons
+ source = https://github.com/domtronn/all-the-icons.el/archive/2.5.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-all-the-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c545fd6eeb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-all-the-icons
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="A utility package to collect various Icon Fonts and propertize them within Emacs."
+url="https://github.com/domtronn/all-the-icons.el"
+arch=('any')
+license=('MIT')
+depends=('emacs' 'emacs-font-lock-plus')
+makedepends=('git')
+provides=('emacs-all-the-icons')
+source=("https://github.com/domtronn/all-the-icons.el/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/all-the-icons.el-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+ emacs -q --no-splash -batch -L . -f batch-byte-compile data/*.el
+}
+
+package() {
+ cd "${srcdir}/all-the-icons.el-${pkgver}"
+ install -d "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons/"
+
+ mkdir ${pkgdir}/usr/share/emacs/site-lisp/all-the-icons/data/
+ mkdir ${pkgdir}/usr/share/emacs/site-lisp/all-the-icons/fonts/
+
+ install -D -m644 data/* "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons/data/"
+ install -D -m644 fonts/* "${pkgdir}/usr/share/emacs/site-lisp/all-the-icons/fonts/"
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}