summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquin2018-03-28 08:00:54 -0500
committerJoaquin2018-03-28 08:00:54 -0500
commit9102099c16cce6147da28a0e1f838ed2e8bf4682 (patch)
tree7aa1d0bf8bef987abcca601b06873ca42aab9989
downloadaur-9102099c16cce6147da28a0e1f838ed2e8bf4682.tar.gz
Initial upload: annie-git 0.6.2.r5.g7f029d2-1
Initial upload: annie 0.6.2-1 upgpkg: android-platform 27_r01-2 Adding Package: Annie
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5704ffd150d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = annie-git
+ pkgdesc = A fast, simple and clean video downloader written in Go
+ pkgver = 0.6.2.r5.g7f029d2
+ pkgrel = 1
+ url = https://github.com/iawia002/annie
+ arch = any
+ license = MIT
+ makedepends = go
+ depends = ffmpeg
+ provides = annie
+ conflicts = annie
+ source = git+https://github.com/iawia002/annie
+ sha256sums = SKIP
+
+pkgname = annie-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a70a9af98dd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Joaquin Garmendia <joaquingc123 at gmail dot com>
+
+# All my PKGBUILDs can be found in https://www.github.com/joaquingx/PKGBUILDs
+
+pkgname=annie-git
+pkgver=0.6.2.r5.g7f029d2
+pkgrel=1
+arch=('any')
+pkgdesc="A fast, simple and clean video downloader written in Go"
+url="https://github.com/iawia002/annie"
+license=("MIT")
+makedepends=("go")
+depends=("ffmpeg")
+provides=("annie")
+conflicts=("annie")
+source=("git+${url}")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "${pkgname%-git}"
+ go build
+}
+
+package(){
+ install -Dm755 "${srcdir}/${pkgname%-git}/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+}
+