summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-07-31 03:09:27 +0200
committerCarsten Teibes2014-07-31 03:09:27 +0200
commit916f3206ae8058cb8fbe799c25e966337e197626 (patch)
treef23a99abb7495f8a1e8ec9038d4d57ca0cb2dcef
downloadaur-916f3206ae8058cb8fbe799c25e966337e197626.tar.gz
[add] fluidsynth-git
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39c7ef1460e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fluidsynth-git
+ pkgdesc = A real-time software synthesizer based on the SoundFont 2 specifications (development version)
+ pkgver = 1.1.6.r418.3e08eae
+ pkgrel = 1
+ url = http://www.fluidsynth.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = glib2
+ depends = jack
+ depends = libpulse
+ depends = alsa-lib
+ depends = ladspa
+ optdepends = pulseaudio: PulseAudio sound support
+ provides = fluidsynth=1.1.6
+ conflicts = fluidsynth
+ source = fluidsynth::git+http://git.code.sf.net/p/fluidsynth/code-git
+ md5sums = SKIP
+
+pkgname = fluidsynth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c195e779684
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=fluidsynth-git
+pkgver=1.1.6.r418.3e08eae
+pkgrel=1
+pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications (development version)"
+arch=('i686' 'x86_64')
+url="http://www.fluidsynth.org/"
+license=('LGPL')
+depends=('glib2' 'jack' 'libpulse' 'alsa-lib' 'ladspa')
+makedepends=('git' 'cmake')
+optdepends=('pulseaudio: PulseAudio sound support')
+conflicts=('fluidsynth')
+provides=("fluidsynth=${pkgver%.r*}")
+source=(${pkgname%-*}::"git+http://git.code.sf.net/p/fluidsynth/code-git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}/${pkgname%-*}
+
+ _major=$(grep -o "FLUIDSYNTH_VERSION_MAJOR.*" CMakeLists.txt | grep -o "[0-9]*")
+ _minor=$(grep -o "FLUIDSYNTH_VERSION_MINOR.*" CMakeLists.txt | grep -o "[0-9]*")
+ _micro=$(grep -o "FLUIDSYNTH_VERSION_MICRO.*" CMakeLists.txt | grep -o "[0-9]*")
+ _rev=$(git rev-list --count HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "$_major.$_minor.$_micro.r%s.%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ cmake ${pkgname%-*} -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -Denable-ladspa=ON \
+ -DLIB_SUFFIX=""
+ make
+}
+
+package() {
+ make -C ${pkgname%-*} DESTDIR="$pkgdir/" install
+}