summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2019-04-02 14:12:01 -0400
committeralgebro2019-04-02 14:14:52 -0400
commit9171020ac721c345355915cb0635522e355060d3 (patch)
treec41f78cb01ef3a88f68d3bfab26cb5a1b3ba4ead
parent82a47b33d711466659d26d486f456cf97c67bbac (diff)
downloadaur-9171020ac721c345355915cb0635522e355060d3.tar.gz
Ship config.txt to handle new config system
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--config.txt54
3 files changed, 65 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b5181732cf1..118aee1195fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lizzie-git
pkgdesc = Analysis interface for Leela Zero
- pkgver = 0.6.r19.g6fa818e
- pkgrel = 1
+ pkgver = 0.6.r84.gfca35c2
+ pkgrel = 2
url = https://github.com/featurecat/lizzie
arch = x86_64
license = GPLv3
@@ -15,9 +15,11 @@ pkgbase = lizzie-git
source = git+https://github.com/featurecat/lizzie.git
source = lizzie.sh
source = lizzie.desktop
+ source = config.txt
sha256sums = SKIP
sha256sums = 58a4987ab4167aab557e1bcd2bb22daec252ce7c6397e76040c038516b74de70
sha256sums = cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0
+ sha256sums = 3487a0b90ca9340abbd456d47f5dcd8cbaa2876625a4122d732f0a77f09f6caf
pkgname = lizzie-git
diff --git a/PKGBUILD b/PKGBUILD
index aaef995c7608..9470e9799438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=lizzie-git
_pkgname=lizzie
-pkgver=0.6.r19.g6fa818e
+pkgver=0.6.r84.gfca35c2
_pkgver=0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Analysis interface for Leela Zero"
arch=('x86_64')
url="https://github.com/featurecat/lizzie"
@@ -16,10 +16,12 @@ provides=('lizzie')
conflicts=('lizzie')
source=("git+https://github.com/featurecat/lizzie.git"
"lizzie.sh"
- "lizzie.desktop")
+ "lizzie.desktop"
+ "config.txt")
sha256sums=('SKIP'
'58a4987ab4167aab557e1bcd2bb22daec252ce7c6397e76040c038516b74de70'
- 'cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0')
+ 'cf5d1651023f04294e580243aa7ef05bc9ebedb468631f4035fd3d5ce0f212f0'
+ '3487a0b90ca9340abbd456d47f5dcd8cbaa2876625a4122d732f0a77f09f6caf')
pkgver() {
cd lizzie
@@ -27,8 +29,6 @@ pkgver() {
}
build() {
- # Use leela-zero-git's weights file instead of downloading a new one just for `mvn test`
- ln -s /usr/share/leela-zero/networks/weights.txt lizzie/network.gz
cd lizzie
mvn package
}
@@ -39,10 +39,8 @@ check() {
}
package() {
- sed -i 's/network.gz/\/usr\/share\/leela-zero\/networks\/weights.txt/g' "$_pkgname"/config.txt
-
install -Dm644 "$_pkgname"/target/lizzie-"$_pkgver"-shaded.jar "$pkgdir"/usr/share/java/"$_pkgname"/"$_pkgname".jar
- install -Dm644 "$_pkgname"/config.txt "$pkgdir"/usr/share/"$_pkgname"/config.txt
+ install -Dm644 config.txt "$pkgdir"/usr/share/"$_pkgname"/config.txt
install -Dm755 "$_pkgname".sh "$pkgdir"/usr/bin/"$_pkgname"
install -Dm644 "$_pkgname".desktop "$pkgdir"/usr/share/applications/"$_pkgname".desktop
}
diff --git a/config.txt b/config.txt
new file mode 100644
index 000000000000..ef1a9b7d9a03
--- /dev/null
+++ b/config.txt
@@ -0,0 +1,54 @@
+{
+ "leelaz": {
+ "max-analyze-time-minutes": 5,
+ "analyze-update-interval-centisec": 10,
+ "network-file": "/usr/share/leela-zero/networks/weights.txt",
+ "max-game-thinking-time-seconds": 2,
+ "engine-start-location": ".",
+ "engine-command": "/usr/bin/leelaz --gtp --lagbuffer 0 --weights %network-file",
+ "print-comms": false
+ },
+ "ui": {
+ "comment-font-size": 0,
+ "board-color": [
+ 217,
+ 152,
+ 77
+ ],
+ "shadow-size": 100,
+ "show-winrate": true,
+ "autosave-interval-seconds": -1,
+ "append-winrate-to-comment": false,
+ "fancy-board": true,
+ "show-captured": true,
+ "replay-branch-interval-seconds": 1,
+ "weighted-blunder-bar-height": false,
+ "win-rate-always-black": false,
+ "show-move-number": false,
+ "winrate-stroke-width": 3,
+ "show-next-moves": true,
+ "show-comment": true,
+ "show-leelaz-variation": true,
+ "theme": "default",
+ "min-playout-ratio-for-stats": 0,
+ "fancy-stones": true,
+ "resume-previous-game": false,
+ "new-move-number-in-branch": true,
+ "shadows-enabled": true,
+ "show-variation-graph": true,
+ "show-dynamic-komi": true,
+ "gtp-console-style": "body {background:#000000; color:#d0d0d0; font-family:Consolas, Menlo, Monaco, 'Ubuntu Mono', monospace; margin:4px;} .command {color:#ffffff;font-weight:bold;} .winrate {color:#ffffff;font-weight:bold;} .coord {color:#ffffff;font-weight:bold;}",
+ "minimum-blunder-bar-width": 3,
+ "large-winrate": false,
+ "show-blunder-bar": true,
+ "only-last-move-number": 0,
+ "confirm-exit": false,
+ "show-status": true,
+ "handicap-instead-of-winrate": false,
+ "large-subboard": false,
+ "dynamic-winrate-graph-width": false,
+ "show-subboard": true,
+ "show-best-moves": true,
+ "board-size": 19
+ }
+} \ No newline at end of file