summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkouta2023-02-21 21:58:04 -0300
committerkouta2023-02-21 21:58:04 -0300
commit91743d3b28a13c961015b931bc7105949364b918 (patch)
tree9821cd38577eceae27031815bc5300fe0bb66274
parent398e7256967eae78296cacab1aae1fe3c13de284 (diff)
downloadaur-91743d3b28a13c961015b931bc7105949364b918.tar.gz
Patch has been upstreamed, no longer necessary
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Fix-compilation-errors-on-format-security.patch87
-rw-r--r--PKGBUILD5
3 files changed, 2 insertions, 92 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 848ddf63dc64..cd12915f1e4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,8 +31,6 @@ pkgbase = ufoai-git
conflicts = ufoai
conflicts = ufoai-data
source = git+git://git.code.sf.net/p/ufoai/code
- source = 0001-Fix-compilation-errors-on-format-security.patch
sha256sums = SKIP
- sha256sums = 18a4cc6cfed138c58f02fd733d19250749ba31d6eaa9078dffb6537bca92eb25
pkgname = ufoai-git
diff --git a/0001-Fix-compilation-errors-on-format-security.patch b/0001-Fix-compilation-errors-on-format-security.patch
deleted file mode 100644
index 0b810ee25fef..000000000000
--- a/0001-Fix-compilation-errors-on-format-security.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From ff198496b716c36f98100286984d3c55be0bed05 Mon Sep 17 00:00:00 2001
-From: kouta-kun <darkfm@vera.com.uy>
-Date: Wed, 14 Dec 2022 01:49:24 -0300
-Subject: [PATCH] * Fix compilation errors on format-security
-
----
- src/client/cl_lua.cpp | 4 ++--
- src/client/ui/swig/ui_lua_shared.cpp | 2 +-
- src/tests/test_rma.cpp | 8 ++++----
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/src/client/cl_lua.cpp b/src/client/cl_lua.cpp
-index acabf49bb2..8cbf74ff35 100644
---- a/src/client/cl_lua.cpp
-+++ b/src/client/cl_lua.cpp
-@@ -67,13 +67,13 @@ static int CL_UfoModuleLoader (lua_State* L) {
- } else {
- /* push error string onto the stack */
- sprintf(errmsg, "Lua custom-loader error: cannot load module named [%s]:\n\t%s\n", module, lua_tostring(L, -1));
-- Com_Printf(errmsg);
-+ Com_Printf("%s", errmsg);
- lua_pushstring(L, errmsg);
- }
- } else {
- /* push error string onto the stack */
- sprintf(errmsg, "Lua custom-loader error: cannot find module named [%s]\n", module);
-- Com_Printf(errmsg);
-+ Com_Printf("%s", errmsg);
- lua_pushstring(L, errmsg);
- }
- /* an error occured, return 0*/
-diff --git a/src/client/ui/swig/ui_lua_shared.cpp b/src/client/ui/swig/ui_lua_shared.cpp
-index c89b86f53b..14b0c9a299 100644
---- a/src/client/ui/swig/ui_lua_shared.cpp
-+++ b/src/client/ui/swig/ui_lua_shared.cpp
-@@ -8,7 +8,7 @@
- * interface file instead.
- * ----------------------------------------------------------------------------- */
-
--
-+#pragma GCC diagnostic ignored "-Wformat-security"
- #ifndef SWIGLUA
- #define SWIGLUA
- #endif
-diff --git a/src/tests/test_rma.cpp b/src/tests/test_rma.cpp
-index c2b366b51c..27041c81c1 100644
---- a/src/tests/test_rma.cpp
-+++ b/src/tests/test_rma.cpp
-@@ -120,7 +120,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblyTimeout)
- const char *self = "RandomMapAssemblyTest.MassAssemblyTimeout";
- unsigned const int numRuns = 10;
- sv_threads->integer = 1;
-- SCOPED_TRACE(va(self));
-+ SCOPED_TRACE(self);
- testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
- }
-
-@@ -129,7 +129,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblyParallel)
- const char *self = "RandomMapAssemblyTest.MassAssemblyParallel";
- unsigned const int numRuns = 10;
- sv_threads->integer = 2;
-- SCOPED_TRACE(va(self));
-+ SCOPED_TRACE(self);
- testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
- }
-
-@@ -139,7 +139,7 @@ TEST_F(RandomMapAssemblyTest, MassAssemblySequential)
- const char *self = "RandomMapAssemblyTest.MassAssemblySequential";
- unsigned const int numRuns = 10;
- sv_threads->integer = 0;
-- SCOPED_TRACE(va(self));
-+ SCOPED_TRACE(self);
- testAssembly(self, numRuns, TEST_THEME, TEST_ASSEMBLY);
- }
-
-@@ -162,7 +162,7 @@ TEST_F(RandomMapAssemblyTest, Seedlists)
- sv_threads->integer = 0;
- long timeSum = 0;
-
-- SCOPED_TRACE(va(self));
-+ SCOPED_TRACE(self);
- for (int n = 0; n < length; n++) {
- timeSum += testAssembly(self, numRuns, assNames[n][0], assNames[n][1]);
- }
---
-2.39.0
-
diff --git a/PKGBUILD b/PKGBUILD
index e4bfb1d4d4f4..d077cb1817c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,9 +18,9 @@ optdepends=('python2: compiling self-created maps'
'gtkglext: compiling the map-editor'
'openal: compiling the map-editor')
conflicts=('ufoai' 'ufoai-data')
-source=(git+git://git.code.sf.net/p/ufoai/code "0001-Fix-compilation-errors-on-format-security.patch")
+source=(git+git://git.code.sf.net/p/ufoai/code)
#source=('git+file:///home/kouta-kun/ufo')
-sha256sums=('SKIP' "18a4cc6cfed138c58f02fd733d19250749ba31d6eaa9078dffb6537bca92eb25")
+sha256sums=('SKIP')
pkgver() {
cd ${_gitname}
@@ -30,7 +30,6 @@ pkgver() {
prepare() {
cd ${_gitname}
- patch --forward --strip=1 --input="${srcdir}/0001-Fix-compilation-errors-on-format-security.patch"
# uncomment the '--enable-uforadiant' line for ufo-radiant (map editor)
./configure --prefix=/usr --datadir=/usr/share/ufoai \
--enable-release --localedir=/usr/share/ufoai/base/i18n/ \