summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-12-04 09:14:30 +0100
committerChristopher Arndt2019-12-04 09:14:30 +0100
commit91a6de3edd103585c57ce652904661164109e2a0 (patch)
treebfad0550ee3427ed3aba46b007f768649b3b5107
parentdc2c544ca8747aeb3ced91d56d9c77b2f5e0456d (diff)
downloadaur-91a6de3edd103585c57ce652904661164109e2a0.tar.gz
Adopting package restview
* Update to latest upstream version 2.9.2 * Use source distribution from PyPi instead of GitHub * Move 'python-setuptools' from makedepends to depends * Fix name of 'build' function * Add '--skip-build' option to 'setup.py install'
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e867f6b4fa6c..d7956172b27c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = restview
pkgdesc = A viewer for ReStructuredText documents that renders them on the fly.
- pkgver = 2.7.0
+ pkgver = 2.9.2
pkgrel = 1
url = http://mg.pov.lt/restview/
arch = any
license = GPL
- makedepends = python-setuptools
depends = python-docutils
depends = python-pygments
depends = python-readme-renderer
+ depends = python-setuptools
options = !emptydirs
- source = https://github.com/mgedmin/restview/archive/2.7.0.tar.gz
- sha256sums = ab288234da5c6b3f7cd02d6112d0a020822f43423c086089efeeda2ffac5c388
+ source = https://files.pythonhosted.org/packages/source/r/restview/restview-2.9.2.tar.gz
+ sha256sums = 790097eb587c0465126dde73ca06c7a22c5007ce1be4a1de449a13c0767b32dc
pkgname = restview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4447c5bc7a84
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+restview-*.tar.gz
+restview-*.pkg.tar.xz
+restview-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c05726da32df..02993629e6e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
-# Contributor: Christopher Arndt <chris@chrisarndt.de>
+# Maintainer: Christopher Arndt <chris@chrisarndt.de>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
pkgname=restview
-pkgver=2.7.0
+pkgver=2.9.2
pkgrel=1
pkgdesc="A viewer for ReStructuredText documents that renders them on the fly."
arch=(any)
url="http://mg.pov.lt/restview/"
license=('GPL')
-depends=('python-docutils' 'python-pygments' 'python-readme-renderer')
-makedepends=('python-setuptools')
+depends=('python-docutils' 'python-pygments' 'python-readme-renderer' 'python-setuptools')
options=(!emptydirs)
-source=("https://github.com/mgedmin/restview/archive/${pkgver}.tar.gz")
-sha256sums=('ab288234da5c6b3f7cd02d6112d0a020822f43423c086089efeeda2ffac5c388')
+source=(
+ "https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+)
+sha256sums=('790097eb587c0465126dde73ca06c7a22c5007ce1be4a1de449a13c0767b32dc')
-package() {
+build() {
cd "${srcdir}"/${pkgname}-${pkgver}
python setup.py build
}
package() {
cd "${srcdir}"/${pkgname}-${pkgver}
- python setup.py install --root="${pkgdir}"/ --optimize=1
+ python setup.py install --skip-build --root="${pkgdir}"/ --optimize=1
}