summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-01-14 20:55:05 +1300
committerGeorge Rawlinson2021-01-14 20:55:05 +1300
commit91bcd4907efefd37c55c2120c1a08b72585b8d88 (patch)
treefc942da5fb99b2daa787512ad75658d8a50e68aa
parent2d8b891c1e63db451370990b32d7faa48eed0b78 (diff)
downloadaur-91bcd4907efefd37c55c2120c1a08b72585b8d88.tar.gz
upgpkg: leocad 21.01-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8da61447dfd..10b9dd996649 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = leocad
pkgdesc = A CAD program for creating virtual LEGO models
- pkgver = 19.07.1
+ pkgver = 21.01
pkgrel = 1
url = http://leocad.org
arch = i686
@@ -9,10 +9,10 @@ pkgbase = leocad
makedepends = qt5-tools
depends = qt5-base
depends = hicolor-icon-theme
- source = leocad-19.07.1.tar.gz::https://github.com/leozide/leocad/archive/v19.07.1.tar.gz
- source = https://github.com/leozide/leocad/releases/download/v18.02/Library-Linux-11494.zip
- sha512sums = 7c7d896920ca0eb2bd9e19080e1532ab76454d6585bee4b09a198f4abff23a7a40b396bc0bdf433f1c7eca99e17c440cbad8f1e5f30b043906e418404438517b
- sha512sums = 2389a1814f4cf94a6a1b449adc2782b8d6cb3c781ecbf75b964f002a35b7283e41c41b0684f4aa70e3d2dd880bd1032b94ecd33b862dbcd9cdf56b88024a5e28
+ source = leocad-21.01.tar.gz::https://github.com/leozide/leocad/archive/v21.01.tar.gz
+ source = leocad-library-20.03.zip::https://github.com/leozide/leocad/releases/download/v21.01/Library-20.03.zip
+ b2sums = c44147221de03e20004d3496016c0b103139707d10f41093230517e1b3f1a64da81effc2b7b8915df885740c2c321ff5bd26722508c7617f6ab200b0f497fc61
+ b2sums = 7fe30da444e0456a413102f2511deb690f6b818dd2626ae7baa2e4b29a197b56d77536f01dfccbcd4428811d89ee4d026361a5ff7506459df036e82e963debfe
pkgname = leocad
diff --git a/PKGBUILD b/PKGBUILD
index be9ded7b6c99..ab16e74f38df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,8 @@
# Contributor: Sven Schneider <archlinux.sandmann@googlemail.com>
pkgname=leocad
-pkgver=19.07.1
+pkgver=21.01
+_libver=20.03
pkgrel=1
pkgdesc="A CAD program for creating virtual LEGO models"
arch=('i686' 'x86_64')
@@ -13,29 +14,30 @@ license=('GPL')
depends=('qt5-base' 'hicolor-icon-theme')
makedepends=('qt5-tools')
source=("$pkgname-$pkgver.tar.gz::https://github.com/leozide/leocad/archive/v$pkgver.tar.gz"
- "https://github.com/leozide/leocad/releases/download/v18.02/Library-Linux-11494.zip")
-sha512sums=('7c7d896920ca0eb2bd9e19080e1532ab76454d6585bee4b09a198f4abff23a7a40b396bc0bdf433f1c7eca99e17c440cbad8f1e5f30b043906e418404438517b'
- '2389a1814f4cf94a6a1b449adc2782b8d6cb3c781ecbf75b964f002a35b7283e41c41b0684f4aa70e3d2dd880bd1032b94ecd33b862dbcd9cdf56b88024a5e28')
+ "$pkgname-library-$_libver.zip::https://github.com/leozide/leocad/releases/download/v$pkgver/Library-$_libver.zip")
+b2sums=('c44147221de03e20004d3496016c0b103139707d10f41093230517e1b3f1a64da81effc2b7b8915df885740c2c321ff5bd26722508c7617f6ab200b0f497fc61'
+ '7fe30da444e0456a413102f2511deb690f6b818dd2626ae7baa2e4b29a197b56d77536f01dfccbcd4428811d89ee4d026361a5ff7506459df036e82e963debfe')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
# create Makefile with QMake
qmake-qt5 \
INSTALL_PREFIX=/usr \
DISABLE_UPDATE_CHECK=1 \
- "${pkgname}.pro"
+ LDRAW_LIBRARY_PATH=/usr/share/leocad \
+ "$pkgname.pro"
# build package
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
- # copy install to pkgdir
- make INSTALL_ROOT="${pkgdir}" install
+ # install to pkgdir
+ make INSTALL_ROOT="$pkgdir" install
# install parts library
- install -Dm644 "${srcdir}/library.bin" "${pkgdir}/usr/share/leocad/library.bin"
+ install -Dm644 "$srcdir/library.bin" -t "$pkgdir/usr/share/leocad"
}