summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreschwartz2020-07-07 20:21:34 +0000
committerJakob Gahde2022-01-05 11:46:17 +0100
commit92159eda37fc93b7a5f5fc436d0aec68dfdce1d8 (patch)
treeb0866156cd28f4136a4cccc41b62bdbb0c6110e6
downloadaur-92159eda37fc93b7a5f5fc436d0aec68dfdce1d8.tar.gz
addpkg: python-httpcore 0.9.1-3: dependency of authlib/httpx
We are going to use this in aurweb. git-svn-id: file:///srv/repos/svn-community/svn@660224 9fca08f4-af9d-4005-b8df-a31f2cc04f65
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..987ca65b275e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-httpcore
+ pkgdesc = A minimal HTTP client
+ pkgver = 0.9.1
+ pkgrel = 3
+ url = https://github.com/encode/httpcore
+ arch = any
+ license = BSD
+ checkdepends = python-pytest-asyncio
+ checkdepends = python-pytest-trio
+ checkdepends = python-trustme
+ checkdepends = mitmproxy
+ makedepends = python-setuptools
+ depends = python-h11
+ depends = python-h2
+ depends = python-sniffio
+ source = python-httpcore-0.9.1.tar.gz::https://github.com/encode/httpcore/archive/0.9.1.tar.gz
+ sha512sums = 5105ff0c19b8a4a34080e79aa1d191199131450e658fbe0949b091e5acfb9cd8b11033757a3bd7dd1490e5fb61352eb44d086babd70d22be33479befd16745fd
+ b2sums = 8f7416c1e726892b152e7e9623790ac1e70b9142f45028b23df25f1d54b6f113f1a79839ec2a7d90b196197d53c880847526c2e47e07d52a0e104a9e2849bccf
+
+pkgname = python-httpcore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a807db5a008b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+_pkgname=httpcore
+pkgname=python-httpcore
+pkgver=0.9.1
+pkgrel=3
+pkgdesc="A minimal HTTP client"
+arch=('any')
+url="https://github.com/encode/${_pkgname}"
+license=('BSD')
+depends=('python-h11' 'python-h2' 'python-sniffio')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest-asyncio' 'python-pytest-trio' 'python-trustme' 'mitmproxy')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha512sums=('5105ff0c19b8a4a34080e79aa1d191199131450e658fbe0949b091e5acfb9cd8b11033757a3bd7dd1490e5fb61352eb44d086babd70d22be33479befd16745fd')
+b2sums=('8f7416c1e726892b152e7e9623790ac1e70b9142f45028b23df25f1d54b6f113f1a79839ec2a7d90b196197d53c880847526c2e47e07d52a0e104a9e2849bccf')
+
+prepare() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ # do not run coverage in unittests!
+ sed -i '/^addopts/d' setup.cfg
+}
+
+build() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python -m pytest
+}
+
+package() {
+ cd "${srcdir}"/${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.md
+}