summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrougnouf (Benoit Brummer)2020-10-25 10:42:02 +0100
committertrougnouf (Benoit Brummer)2020-10-25 10:42:02 +0100
commit9215e3653101f488e12e4177da34b0e4075fe411 (patch)
tree9128c37575ceaf6056afa30b2b09476c0d898252
parent69c4f39415c4c2e518986aa0e02b00c066e26bfd (diff)
downloadaur-9215e3653101f488e12e4177da34b0e4075fe411.tar.gz
fix wx-config compile error per ruppor
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f1e2253fd89..7a4606b3016d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=opencpn
_name="OpenCPN"
pkgver=5.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Open Source Chart Plotting / Marine Navigation"
arch=('x86_64' 'aarch64')
license=("GPL2")
@@ -19,6 +19,13 @@ install=opencpn.install
source=("https://github.com/${_name}/${_name}/archive/Release_${pkgver}.tar.gz")
sha1sums=('157d7392e42a8ee9b6efbb6496642e575ad958fa')
+prepare() {
+ cd "OpenCPN-Release_${pkgver}"
+ export PATH="$PWD/bin:$PATH"
+ mkdir bin
+ ln -s /usr/bin/wx-config-gtk3 bin/wx-config
+}
+
build() {
cd "OpenCPN-Release_${pkgver}"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \