summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmaël Bouya2016-10-30 10:07:15 +0100
committerIsmaël Bouya2016-10-30 11:21:54 +0100
commit921c3505ba2e9c5715f858bafdad2ab61027d1be (patch)
tree42cfb4209d01465945e75f9c6d4b00ff06e2d515
downloadaur-921c3505ba2e9c5715f858bafdad2ab61027d1be.tar.gz
Initial commit to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29d52b4cdc58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Oct 30 09:07:15 UTC 2016
+pkgbase = g3data
+ pkgdesc = A tool for extracting data from scanned graphs.
+ pkgver = 1.5.4
+ pkgrel = 1
+ url = https://github.com/pn2200/g3data
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gtk2>=2.6
+ source = https://github.com/downloads/pn2200/g3data/g3data-1.5.4.tar.gz
+ md5sums = acb41e54ee5fbf167413218f209c4e3f
+
+pkgname = g3data
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c91eba9a41ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer : Immae <ismael.bouya@normalesup.org>
+# Contributor: <clu>
+# Contributor: Dominik Fuchs <dominik.fuchs@wur.nl>
+# Contributor: Michele Vascellari
+
+pkgname=g3data
+pkgver=1.5.4
+pkgrel=1
+pkgdesc="A tool for extracting data from scanned graphs."
+arch=('i686' 'x86_64')
+url="https://github.com/pn2200/g3data"
+license=('GPL2')
+depends=('gtk2>=2.6')
+makedepends=()
+source=(https://github.com/downloads/pn2200/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('acb41e54ee5fbf167413218f209c4e3f')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=${pkgdir}/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make install
+}