summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthibsc2019-07-12 19:29:08 +0200
committerthibsc2019-07-12 19:29:08 +0200
commit923951b2abd0bcf30f673d60d3f24dd9ad1eee53 (patch)
tree5c35052803cc93b582487666434ca4bad5a99598
downloadaur-923951b2abd0bcf30f673d60d3f24dd9ad1eee53.tar.gz
First upload for Flynote package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD34
-rw-r--r--flynote.desktop10
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b4877b6c9bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = flynote-git
+ pkgdesc = A program to take note on desktop like a Post-It and share on LAN
+ pkgver = r41.fcc41e6
+ pkgrel = 1
+ url = https://github.com/thibsc/flynote
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ source = git+https://github.com/thibsc/flynote.git
+ source = flynote.desktop
+ sha256sums = SKIP
+ sha256sums = 58c0116f4a41b5e5a0745a6bcdbf0586b8ea44baa33e10a461052f6db0877461
+
+pkgname = flynote-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9e0e92f0138d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# but note these files
+!flynote.desktop
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9aa070b8d583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: ThiBsc <thibsc at tutanota dot com>
+pkgname=flynote-git
+_gitname=flynote
+pkgver=r41.fcc41e6
+pkgrel=1
+pkgdesc="A program to take note on desktop like a Post-It and share on LAN"
+arch=('any')
+url="https://github.com/thibsc/flynote"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git')
+source=("git+${url}.git"
+ "${_gitname}.desktop")
+sha256sums=('SKIP'
+ '58c0116f4a41b5e5a0745a6bcdbf0586b8ea44baa33e10a461052f6db0877461')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ mkdir build && cd build
+ qmake -config release ../flynote.pro
+ make
+}
+
+package() {
+ install -Dm755 ${srcdir}/${_gitname}/build/${_gitname} ${pkgdir}/usr/bin/${_gitname}
+ install -Dm644 ${srcdir}/${_gitname}/icons/note.png ${pkgdir}/usr/share/pixmaps/flynote.png
+ install -Dm755 ${srcdir}/${_gitname}.desktop ${pkgdir}/usr/share/applications/${_gitname}.desktop
+}
+
diff --git a/flynote.desktop b/flynote.desktop
new file mode 100644
index 000000000000..a7c2995341a4
--- /dev/null
+++ b/flynote.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Flynote
+GenericName=Flynote
+Comment=Desktop Post-It program
+Categories=Utility;Office
+Exec=/usr/bin/flynote
+Icon=flynote.png
+StartupNotify=false
+Terminal=false
+Type=Application \ No newline at end of file