summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2015-08-26 11:32:42 -0400
committerDavid Manouchehri2015-08-26 11:32:42 -0400
commit9244b0fb199402c7f10efc917541b7455c72e3c3 (patch)
tree06c7865079c794f128ed823fcaf20c6f681f4c14
downloadaur-9244b0fb199402c7f10efc917541b7455c72e3c3.tar.gz
Initial import from AUR3.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9be53489a8a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gimp-plugin-imgur-git
+ pkgdesc = A very simple gimp plugin to upload the current image anonymously to imgur.
+ pkgver = r11.027a23c
+ pkgrel = 1
+ url = https://github.com/utecht/gimp_imgur
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gimp
+ source = git://github.com/utecht/gimp_imgur.git#branch=master
+ sha512sums = SKIP
+
+pkgname = gimp-plugin-imgur-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5026cfca75a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: David Manouchehri <d@32t.ca>
+
+pkgname=gimp-plugin-imgur-git
+_gitname=gimp_imgur
+_gitbranch=master
+_gitauthor=utecht
+pkgver=r11.027a23c
+pkgrel=1
+pkgdesc="A very simple gimp plugin to upload the current image anonymously to imgur."
+license=('GPL')
+arch=('i686' 'x86_64')
+url="https://github.com/$_gitauthor/$_gitname"
+depends=('gimp')
+source=("git://github.com/$_gitauthor/$_gitname.git#branch=$_gitbranch")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/gimp/2.0/plug-ins
+ install -m 0755 "$srcdir/$_gitname/"*".py" "$pkgdir"/usr/lib/gimp/2.0/plug-ins
+}